Warnhinweis bei veralteten Browsern 1.0.4

Lizenzbestimmungen
Kostenlose Plugins
Website
https://www.mysterycode.de
Unterstützte Versionen
Burning Board 4.0 / WCF 2.0
Burning Board 4.1 / WCF 2.1

Zeigt bei Benutzung von veralteten (nicht unterstützten) Browserversionen einen Hinweis an.

Zeigt bei Benutzung von veralteten (nicht unterstützten oder benutzerdefinierten) Browserversionen einen Hinweis ein. Dieses Plugin basiert auf browser-update.org.


Sprachen (ACP):

  • Deutsch
  • Englisch

Anzeige-Typen:

  • Fehler (rot)
  • Information (blau)
  • Warnung (gelb)


Beachten Sie in Ihrer Datenschutzerklärung, dass eventuell (je nach gewählter Informationsquelle) eine Verbindung zu static.mysterycode.de aufgebaut wird, wodurch der Traffic des Clients sowohl durch CloudFlare als auch unseren Server geht.


Support und Vorschläge nur hier:
support.mysterycode.de


GitHub:
https://github.com/MysteryCode…erycode.wcf.browserUpdate

Bilder

  • Version 1.0.4

    • JavaScript in eigener Datei
    • JavaScript wird minimiert, sobald der Debug-Modus abgeschalten ist
    • Abfrage der Daten bei externer Quelle jetzt auch via SSL möglich
    • Aktualisierung der Versionsanforderungen
    • Fallback im Falle einer Erreichbarkeitsstörung bei externer Quelle
  • Version 1.0.2

    • Warntext in Sprachvariable ausgelagert
    • Kein 3rdparty-Script mehr benötigt
    • Möglichkeit die aktuellen Versionen von http://static.mysterycode.de/browserupdate/browserUpdate.js abzufragen
  • Version 1.0.1

    Changelog:
    - Versionsnummern für aktuelle Browser ins Template ausgelagert
    - Versionsnummern aktueller Browser aktualisiert

  • Version 1.0.0

  • Ich hatte die Version 1.0.3 des Plugins installiert und plötzlich das Problem, dass einige Benutzer im Editor keine Symbole mehr sahen und somit auch keine Beiträge mehr schreiben konnten.
    Nach der Deinstallation dieses Plugins ist nun wieder alles in Ordnung. Die Benutzer sind wieder zufrieden und können ihre Beiträge schreiben... ;)
    --> http://support.mysterycode.de/…rter-Editor-m%C3%B6glich/

  • Wird die 1.0.3 auch hier hochgeladen? Leider ist dein Updateserver passwortgeschützt.

  • Tolles Plugin, wobei den Netscape Navigatior hätte man da echt getrost weglassen können, ist ja offiziell eingestellt und nimmt auch kein Mensch mehr her. :)

  • Hallo , habe das packet gerade installiert und bekomme 500 Internal Server Error , habe es wieder deinstalliert bekomme den fehler aber leider nicht weg

    • Dann schau bitte in die Logs, bzw. bitte deinen Hoster darum. Das Plugin kann - v.a. nach der Deinstallation - eigentlich keinen 500er auslösen.

    • Ok, entschuldige mich mal, lag am Anbieter der hatte irgendwie Probleme

  • Support und Vorschläge ausschließlich hier: http://support.mysterycode.de

  • Ich finde die Sprachvariable nicht, die den Ausgabetext für den Benutzer enthält. Wie heißt sie denn?

  • Wie aktuallisiere ich auf 1.01? Muss ich 1.0.0 vorher deinstallieren?

  • Habe mir soeben die V1.0.1 installiert. Aber bei den Versionsnummern der Browser hat sich nichts geändert. Hatte mir vorher extra einen Screenshot erstellt...

    • Die, die sich geändert haben, stehen auch nicht im ACP, sondern sind im Template vorgegeben und greifen bei "Benutzerdefinierte Browserversionen". Die Optionsfelder im ACP greifen nur, wenn man "Benutzerdefinierte Browserversionen" anwählt.

    • Danke. Dann weiß ich Bescheid...

    • Ups, im ersten Satz muss es selbstverständlich "Inaktuelle Browserversionen" heißen. ;)

    • Wunderte mich schon... :)

  • Es wäre schön, wenn man optional auch ein Overlay auf der Seite anzeigen lassen könnte. Ich persönlich finde diese kleine Meldung dort nämlich recht unscheinbar :D

    • Solange die immer korrekt angezeigt werden kann ich mir das für die kommende Version 1.1.0 vornehmen (mit einer Select-Option im ACP versteht sich). :)

  • Das wesentliche ist für mich eigentlich, Besucher mit im Forum "nicht mehr unterstützten" Browsern zu invormieren. Ob Ihr Browser auf dem neusten Stand ist, ist mir Schnurz.

    • Dann wählst du "Mindestanforderungen von WoltLab" in den Optionen aus. Der Rest ist für anspruchsvollere Administratoren. :)

  • Es wäre ggf. interessan wenn das plugin die aktuelle Version sich selbst irgendwo her holt. Es kommen so häufig updates (FF) das man da nicht unbedingt immer nachhalten kann bzw. es zu viel Arbeit ist.

    • Es gibt aktuell keine Quelle, aus der ich die Versionen beziehen könnte; ich könnte das höchstens auf meinen eigenen Server auslagern. Angedacht ist momentan, die Versionen per Update 1.0.x oder 1.0.0 pl x aktuell zu halten, da sich das an browser-update.org orientiert.

    • Das wäre echt spitze! Denn bei dem Schritttempo wie die Browser aktualisiert werden... kann man nicht mehr nachhalten ;)

    • Gibt es schon news dazu?

    • Ich werde in den nächsten Tagen zunächst ein Update mit aktualisierten Versionen veröffentlichen, sprich 1.0.1. Eine externe Datei von meinem Server einbinden werde ich bis auf weiteres nicht. Unter anderem, weil ich dann theoretisch die Möglichkeit hätte Code einzuschleusen. Ich kann auf meiner Website aber auch eine modifizierte Version veröffentlichen, wenn der Wunsch sehr dringen ist.

    • Sehr dringend ist es nicht. Nur bin ich zu faul das manuell jedes jedesmal anzupassen :D

  • Vielen Dank für dieses Plugin!