Tabmenu-BBCode 1.0.9

License Agreement
Creative Commons <by-nc-sa>
Website
http://terratex.eu
Supported Versions
Burning Board 4.0 / WCF 2.0
Burning Board 4.1 / WCF 2.1

This BBCode adds the ability to use tabs


This BBCode adds the ability to use Tabs. In front of any tab-title can be an icon.
As Icon can be used FontAwesome too.


Syntax:


Code
  1. [tabmenu]
  2. [tab='title1','icon'] Content 1
  3. [tab='title2,'icon']
  4. [subtab='subtitel1','icon']Content 2
  5. [/tabmenu]


The icon can be an url to an image or the name of the FontAwesome icon (if supported by woltlab) f.e. icon-glass


Informations, Bugs or Suggestions can be postet or found on our Homepage or at GitHub https://github.com/geramy92/BBCode-Tabs

  • Version 1.0.9

    Bugfix for wrong BBCode Usage

  • Version 1.0.8

    Add a fix for some resonsive issues related to other bbcodes

  • Version 1.0.7

    Add $(document).ready(), which fixes some bugs with other plugins in user profile

  • Version 1.0.6

    Die Datei der Klasse ist jetzt groß geschrieben, da dies teilweise zu Fehlern in case-sensitiven System führte.

  • Version 1.0.5

    Behebt einen Fehler mit den Icons der Subtabs, bei dem die Icons nicht richtig angezeigt wurden.

  • Version 1.0.4

    Einige Templatefixes

  • Version 1.0.0

    Version 1.0.0


    * @Author Nerdus, Changes by: Geramy
    * @copyright 2010 Bergwerk
    * @license Creative Commons - Attribution-Noncommercial-Share Alike 3.0 Unported <http://creativecommons.org/licenses/by-nc-sa/3.0/>


    Features:
    - icon-Support (war von Usern gewünscht)
    - FontAwesome-Icons (war von Usern gewünscht)
    - TabMenü wie bei WBB3.1 von Bergwerk

  • Ich bräuchte das Plugin für Suite 5.08...wo bekomme ich das?


    MFG

  • was kann dieses plugin

  • Moin, wird es eine Version für das WSC 3.0 geben?

    • von meiner Seite nicht, da ich kein Woltlab mehr nutze. Allerdings sind die Lizenzen so gesetzt, dass es jeder übernehmen kann.

  • Hi, ich weiß es ist noch recht früh aber wirst Du deinen BBCode für das WSC 3.0 anpassen? Finde deinen BBCode nämlich spitzenmäßig aber leider läuft er derzeit nicht unter dem WSC 3.0. Findet das TabMenu-Template nicht.


    Liebe Grüße

    • Zum aktuellen Zeitpunkt kann ich dazu noch nichts sagen. Ich bin derzeit am Überlegen ob ich mir überhaupt eine Lizenz für das WSC3 (WBB4) besorge, da es mir ehrlich gesagt nicht so gefällt.

    • Hi Geramy , danke für Deine Antwort.


      Aber gut zu wissen, dass es noch nicht feststeht. Was ich auf jeden Fall sagen kann, ist, dass Dein Tabmenü-BBCode eine wahnsinnig tolle Bereicherung für jedes Forum/jede Seite ist ;).
      Damit kann man wahnsinnig übersichtliche Sachen erstellen.


      Daher würde es mich (und sicherlich einige andere) freuen, wenn Du irgendwann vielleicht eine angepasste Version für das WSC 3.0 machst.


      Liebe Grüße und nochmal danke für Deine Antwort.

    • Kann mich KevG nur anschließen, das Tab-Menü ist seit WBB3 bei uns das wichtigste BBCode, welches nicht fehlen darf. Es wäre also sehr nett, wenn du für die Allgemeinheit eine Anpassung machen würdest. Ich denke, dass viele selbst bereit sind einen kleinen Obulus zu bezahlen, falls es von dir gewünscht / notwendig wäre.

    • Da kann ich mich nur anschließen.
      Gibt es schon weitere Informationen?

  • Das Tabmenü funktioniert leider im Dashboard so gut wie gar nicht. Man sieht nur den Inhalt des ersten Tabs, alle weiteren werden nicht angezeigt und wenn man sie durchklickt, hängen sie sich auf. Einsehbar in der obersten "News" auf dem Dashboard: http://www.classickhorinis.de/wbb/

    • Eigentlich sollte das tabmenü gar nicht im Dashboard sichtbar sein.
      Edit: Huch okay einen Teil meiner Antwort muss ich wohl korrigieren. Allerdings muss ich dazu sagen, dass Woltlab einfach den Beiträge normal rändert und dennoch Abschneidet macht es nicht wirklich möglich das Tabmenü vollständig darzustellen

    • Also gibt es keine Möglichkeit das ganze im Dashboard problemlos darzustellen?

    • Ich weiß nicht, ob woltlab da inzwischen noch eine dritte Darstellungsform hat, aber ansonsten wäre es mir nicht bekannt. Aber das Problem an sich ist dennoch, dass wenn sie was haben ich das Tabmenü nicht vollständig rendern kann, da selbst der BBCode bereits unvollständig ankommt

  • Bei folgendem Parse gibt es einen Error für Dashboard, Forenauflistung etc. Liegt wohl daran, dass die Bezeichnungen bzw. der Inhalt der Subtabs ohne "=" eingefügt wurde.


    Error: PHP notice in file /var/www/samp-forum/wcf/lib/system/bbcode/TabmenuBBCode.class.php (231): Undefined offset: 0
    /var/www/samp-forum/wcf/lib/system/WCF.class.php (309)


    "[tabmenu][tab='Montag',][subtab????][tab='Dienstag',][subtab=????][tab='Mittwoch',][subtab??????][tab='[tab='Donnerstag',][subtab=][/tabmenu]"

    • ich würde eher sagen der bbcode ist da völliger blödsinn
      Ich habe mal gefixxt, das eine solche fehlerhafte Verwendung das Forum crashed. [Fix in paar Tagen auf Woltlab oder in meinem Paketserver]

    • Der BBCode ist blödsinn richtig, leider wurde der aber so von einem Nutzer eingefügt. Dann danke für die schnelle Reaktion sowie schon einmal für den zukünftigen Fix ;)

  • Ist es möglich einen Aktiven Tab auch zu Definieren? Also Wenn man 4 Tabs hast 1,2,3,4 aber man möchte das Tab 3 der Tab ist der Offen ist wenn man den Beitrag aufruft! Wäre sowas möglich mit einzubauen und vielleicht auch den Default SubTab zu definieren? Das würde das Plugin abrunden! :)

  • Habe Wbb 4.1 Wenn ich den Code einbaue . dann sagt er mir es ist eine Weiterleitung einmgebaut und komme nicht mehr auf s Baord. Bin ich einfach nur zu b.............. ?????????????
    Oder habe ich was vergessen ????

    • der BBCode funktioniert problemlos unter WBB4.1 Er ändert auch nichts an irgendwelchen Weiterleitungen etc. Er kommt erst beim rendern der Beiträge zur Geltung

  • Sehr gutes Plugin. Habe aber eine kleine Anmerkung: Schreibt man direkt über dem tabmenu-BBCode etwas, so ragt der aktive Tab in dieses Wort hinein (zumindest in Buchstaben, die unter die Grundlinie gehen).

  • Ein kleines Beispiel in der Übersicht wie das ganze im Endeffekt dann aussieht wäre schön gewesen.

  • Hallo,
    ich habe das Problem, dass die Tabs in "Über mich" bei den Mitgliedern nicht mehr funktioniert, wenn man man die Tabs im Profil der Mitglieder mit folgendem Plugin anders sortiert:
    https://pluginstore.woltlab.co…en%C3%BCpunkte-sortieren/


    Ist es möglich, das Problem irgendwie zu beheben?


    Vielen Dank

  • Ist auch eine Version für die WBB Version 4.1.x geplant?

  • Erst mal - Hut ab - bei uns ist dies der am meißt genutzte Zusatz-BBCode ;) ....


    Ein kleines Problem hab ich allerdings:
    Beim Auswählen der Tabs werden ja Adressen in der Art "../Thread/4393-Made-testet/?postID=6638#555707a72d596_0_1" verwendet.
    Ein User bei mir würde gern direkt auf Subtab's verlinken, was leider mit dieser URL nicht funktioniert - es wird immer der erste TAB angezeigt. Gibt es hierfür eventuell eine Lösung? Ich verwende Burning Board 4.0 / WCF 2.0

    • Ehrlich gesagt wüsste ich aus dem Stehgreif nicht wirklich eine. Ich nutze an der Stelle hauptsächlich das TabMenü von Woltlab selbst. Welches nur durch den BBCode generiert wird. Ich kann ja mal drüber nachdenken, vllt. fällt mir was ein.

  • Hallo Geramy, kannst du vielleicht dein Plugin updaten und zwar bei wbb 4.1 wird dein Icon im Editor nicht in weiß dargestellt, wenn man den Editor auf WYSIWYG klickt. DANKE im voraus.

  • Hallo Geramy, vielen Dank erstmal für dieses schöne Plugin. Wir haben im Moment nur ein Problem:
    Wir haben WBB 4.0.9 und Tabmenü 1.0.6
    Die Subtabs werden im ersten Beitrag auf einer Seite immer korrekt angezeigt, beim zweiten und folgenden Beitrag eines Users aber immer irgendwie alle zusammen angezeigt.
    Kennen Sie dieses Problem?
    Viele Grüße
    Mac_gc


    PS: Der Fehler bezieht sich darauf, wenn man das Tabmenü in die Signatur schreibt.

  • Vielen Dank für dieses Plugin, das wir teilweise sehr gut nutzen können! Tolle Arbeit und danke das es kostenlos ist!

  • Weist du vielleicht, warum der BB Code am Ende nicht mehr Stackt und das Dropdown Fenster hat? http://puu.sh/bAkgl/bf99511804.png

    • ich nutze hier nur die standardfunktion von woltlab und hab eigentlich auch die css einstellungen davon. Ich muss zugeben, dass ich nie getestet hab ob das so geht

    • Okay, also gibt es da keine wirkliche Abhilfe wenn man mehr Tabs als Platz hat?

    • bisher nicht, wenn die standardwoltlabfunktion das nicht bietet. Aber ich kann ja mal schauen ob ich in den Zukünftigen Versionen was basteln kann

    • Das fände ich auf jeden Fall super :)

  • In der aktuellen Version kommt es zu einem Fehler, wenn das System case sensitive ist. Bitte stell sicher, dass der erste Buchstabe des Dateinamens der Klasse wcf\system\bbcode\TabemenuBBCode wie vorgesehen groß geschrieben ist. Derzeit ist er es nicht, was wie gesagt bei Systemen, die auf case sensitivity prüfen zu einem Fehler führt. Nach dem ich's manuell geändert habe scheint das BBCode problemlos zu laufen.

  • Huhu, bei mir hat sich ein Problem ergeben, was ich doch verwunderlich finde: Ihre Nachricht enthält die folgenden BBCodes, die Sie nicht verwenden dürfen: progressbar - Jedoch sind dort, aus Vorgängerzeiten, solche Tabs beinhaltet und laut der Definition, dass Kindelemente erlaubt sind (all), sollte es doch eigentl. kein Problem damit geben oder ist irgendetwas falsch eingestellt?

    • Hab den Fehler gefunden, bitte gucken, ob du über eine der vielen options.xml's angeben kannst, dass Benutzergruppe XY (am besten die Standartgruppen), die BBCodes auch verwenden dürfen, ist mir eben aufgefallen ^^

    • kennst du einen BBCode der das bei der Installation kann? Über eine options.xml oder ähnliches ist dies NICHT möglich. Es ginge nur via eines Installationsscriptes. Was aber auch nicht immer sinnvoll ist. Ich frage dennoch danach ob du eines kennst, da ich ggf. nicht alle varianten kenne. Ich halte allerdings eine eigene Erstellung eines Scriptes an dieser Stelle für übertrieben, da der Nutzen wesentlich kleiner ist.

    • Hmmm, ein Blick in die dementsprechenden Klassen zeigte mir, dass so eine Option leider fehlt, also muss ich mal gucken, in welcher Verbindung die Option zu den BBCodes mit der Gruppe steht ...

  • Funktioniert in WBB 4.0.8 nicht. Ich schick Ihnen den Stacktrace mal per PN

  • Ich habe noch rückstände des 3er Tabmenü BB Codes bei mir im Forum. Wenn ich diese Themen aufrufe erhalte ich folgende Fehlermeldung: Wed, 20 Aug 2014 01:16:36 +0000 Message: Unable to find class 'wcf\system\bbcode\TabmenuBBCode' File: /home/jail/kleinefarm/home/nkb-modding/wcf/lib/data/ProcessibleDatabaseObject.class.php (38) PHP version: 5.4.4-14+deb7u12 WCF version: 2.0.8 (Maelstrom) Request URI: /index.php/Thread/?postID=5317 Referrer: User-Agent: Mozilla/5.0 (compatible; MJ12bot/v1.4.5; http://www.majestic12.co.uk/bot.php?+) Information: "" Stacktrace: #0 /home/jail/kleinefarm/home/nkb-modding/wcf/lib/system/bbcode/BBCodeParser.class.php(365): wcf\data\ProcessibleDatabaseObject->getProcessor() #1 /home/jail/kleinefarm/home/nkb-modding/wcf/lib/system/bbcode/BBCodeParser.class.php(99): wcf\system\bbcode\BBCodeParser->buildParsedString() #2 /home/jail/kleinefarm/home/nkb-modding/wcf/lib/system/bbcode/MessageParser.class.php(112): wcf\system\bbcode\BBCodeParser->parse('[align=center] ...') #3 /home/jail/kleinefarm/home/nkb-modding/lib/data/post/Post.class.php(78): wcf\system\bbcode\MessageParser->parse('[align=center] ...', '1', '0', '1') #4 /home/jail/kleinefarm/home/nkb-modding/lib/data/post/Post.class.php(108): wbb\data\post\Post->getSimplifiedFormattedMessage() #5 /home/jail/kleinefarm/home/nkb-modding/lib/page/ThreadPage.class.php(263): wbb\data\post\Post->getExcerpt() #6 /home/jail/kleinefarm/home/nkb-modding/wcf/lib/page/AbstractPage.class.php(179): wbb\page\ThreadPage->readData() #7 /home/jail/kleinefarm/home/nkb-modding/wcf/lib/page/AbstractPage.class.php(86): wcf\page\AbstractPage->show() #8 /home/jail/kleinefarm/home/nkb-modding/wcf/lib/system/request/Request.class.php(58): wcf\page\AbstractPage->__run() #9 /home/jail/kleinefarm/home/nkb-modding/wcf/lib/system/request/RequestHandler.class.php(108): wcf\system\request\Request->execute() #10 /home/jail/kleinefarm/home/nkb-modding/index.php(10): wcf\system\request\RequestHandler->handle('wbb') #11 {main}

  • Gibt es irgendwann nochmal ein Update? Irgendwie werden Sub-Tabs nicht so geladen, das sie einzelt angezeigt werden, sondern werden alle untereinander angezeigt. :(

    • Update gibts auf terratex.eu --- woltlab lehnt die template änderungen ab, aber beantwortet ja die einfachsten Fragen nicht um es für sie zufriedenstellend umzubauen

  • Das Ganze mal Aktion hier zu sehen: http://www.terrariaforum.de/in…/355-Terraria-Changelogs/ Das beste Plugin im Store überhaupt. Nutze es mehr als alles Andere!

  • Schönheits fehler, schaue dir mal die Tabs unten links an

  • Ruft man ein Benutzerprofil auf und klickt sich durch ein Tabmenü, z.B. beim "Über mich" Feld, dann kommt ständig eine Fehlermeldung wenn man einen Tab anklickt: Der Parameter „menuItem“ fehlt oder ist ungültig. Ansonsten läuft alles wunderbar.