Font Awesome Icon Util 1.1.0

License Agreement
GNU Lesser General Public License (LGPL)
Supported Versions
Burning Board 4.0 / WCF 2.0
Burning Board 4.1 / WCF 2.1

Provides PHP and JavaScript API for selecting Font Awesome icons

Font Awesome Icon Util offers developers a PHP and JavaScript API to work with Font Awesome Icons.


Information about how to use the package can be found in the package's GitHub repository.

  • Version 1.1.0

    Changes:
    • Language item wcf.icon.fontAwesome.dialogTitle is deprecated

  • Version 1.1.0 RC 1

    OptionType for selecting a Font Awesome icon
  • Version 1.0.0

    No changes
  • Version 1.0.0 RC 1

  • Wünsche ein Update auf FontAwesome 4.3

  • Hallo, wollte mal anfragen, wann hier mit der neuen Version für das WCF 2.1 zu rechnen ist?

  • Update geht nicht , Also von 1.0.0 zu Aktuellen

    • Das solltest du vielleicht ein wenig weiter ausführen.

    • An update of package com.maasdt.wcf.fontAwesomeIconUtil from version 1.0.0 to 1.1.0 is not supported.

    • Ich bin überfragt, die Update-Anweisungen sind korrekt im Paket hinterlegt.

    • Um zusammenzufassen: Aktuell ist Version 1.0.0 installiert und es soll auf die aktuelle Version 1.1.0 aktualisiert werden. Wie wird das Update vorgenommen (manuelle oder per automatischem Update), wird das Paket einzeln aktualisiert oder zusammen mit einem anderen Paket?


      Die Zeile, in der die Exception in PackageInstallationScheduler geworfen wird (siehe komplette Fehlermeldung) wäre auch interessant.

    • Genau. Es sollte als Automatisches Update installiert werden, es war das einzigste was Upzudaten war. Stacktrace:


      #0 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\system\package\PackageInstallationScheduler.class.php(499): wcf\system\package\PackageInstallationScheduler->findShortestUpdateThread('com.maasdt.wcf....', Array, '1.0.0', '1.1.0')
      #1 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\system\package\PackageInstallationScheduler.class.php(102): wcf\system\package\PackageInstallationScheduler->updatePackage('34', '1.1.0')
      #2 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\system\package\PackageInstallationScheduler.class.php(64): wcf\system\package\PackageInstallationScheduler->tryToInstallPackage('com.maasdt.wcf....', '1.1.0', true)
      #3 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\data\package\update\PackageUpdateAction.class.php(497): wcf\system\package\PackageInstallationScheduler->buildPackageInstallationStack()
      #4 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\data\package\update\PackageUpdateAction.class.php(449): wcf\data\package\update\PackageUpdateAction->createQueue('update')
      #5 [internal function]: wcf\data\package\update\PackageUpdateAction->prepareUpdate()
      #6 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\data\AbstractDatabaseObjectAction.class.php(182): call_user_func(Array)
      #7 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\action\AJAXProxyAction.class.php(76): wcf\data\AbstractDatabaseObjectAction->executeAction()
      #8 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\action\AJAXInvokeAction.class.php(96): wcf\action\AJAXProxyAction->invoke()
      #9 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\action\AbstractAction.class.php(49): wcf\action\AJAXInvokeAction->execute()
      #10 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\action\AJAXInvokeAction.class.php(63): wcf\action\AbstractAction->__run()
      #11 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\system\request\Request.class.php(58): wcf\action\AJAXInvokeAction->__run()
      #12 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\wcf\lib\system\request\RequestHandler.class.php(108): wcf\system\request\Request->execute()
      #13 C:\Inetpub\vhosts\h2338918.stratoserver.net\tf-portal.eu\acp\index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)
      #14 {main}


      Nach einen erneuten versuch ging es dann, das Update.

  • ne klappt nicht

  • warum zeigt es immer fehler an beim update ?