Teralios' BBCodes 2.2.2

License Agreement
Creative Commons <by-sa>
Website
http://wbb-center.net/board/index.php/Board/212-Teralios-Journal-System-BBCodes/
Supported Versions
Burning Board 4.0 / WCF 2.0
Burning Board 4.1 / WCF 2.1

This is a small collection of bbcodes for WCF.


When you use FireBall CMS from code quake, you have installed the Font Awesome Icon BBCode (de.codequake.bbcode.icon). This is a optional package. You must de-installed from your WCF2.1, then you can install my bbcode package! My package will replace the functionality of the icon bbcode complete with some more functions!


Description
This package contains some bbcodes for the wcf. This are headings, a pro and contra list, definition list, footnotes and content boxes.
Usage (short version)
Headings

Code
  1. [h1]Heading[/h1]
  2. [h2]Heading[/h1]





Pro contra list

Code
  1. [pclist][+]postive
  2. [-]negative
  3. [.]neutral[/pclist]





Icon

Code
  1. [icon]fa-file[/icon] Use font awesome css classes





Footnotes

Code
  1. [fn]Some text[/fn]





Defintion list

Code
  1. [dlist][.]Key[:]value[/dlist]




For a full description use: BBCode - Wie setze ich sie richtig ein! (German version).


Update from 1.5.0 to 2.0.0 (WCF2.1)
Step 1: Delete all my packages.
Step 2: Make the update to WCF 2.1
Step 3: Re-install the bbcodes.
Step 4: Install the packages for blog and/or wbb. (This package are needs for the best experience)
Step 5: Got to Rebuild data under Maintenance and use Change old bbcode syntax to new (**)


Report a Bug
You can use the Issue-Tracker on Github.

Images

  • Version 2.2.2


    • Add support for FontAwesome 4.4
    • Changes for a future package
    • Small improvments

  • Version 2.2.1


    • Remove optionals packages.
    • Add forgotten 24 in icon dialog.
    • Small changes in css-code.

  • Version 2.2.0


    • Icons inherits color from color-bbcode.
    • Now also size 24 is selectable for icons.
    • Icon dialog over the rebelle icon.
    • Attachments have a own dialog to put them in the text.
    • Remove small css issues.

  • Version 2.1.0 Pl 1


    • Remove broken preg_match in pro contra bbcode.

  • Version 2.1.0


    • Remove error with editor for signatures.

  • Version 2.1.0 RC 1


    • Revision of attributes for h1, h2, cbox and pclist bbcodes.
    • Revision of alternative attributes of icon bbcode.
    • Improvements for remove of needless br elements.
    • Remove errors in syntactic sugar (WCF conform syntax).

  • Version 2.0.4


    • Kills <br /> after block elements.
    • Better work-a-round for WCF::requestURI.


  • Version 2.0.3 Pl 3


    • Exclude FontAwesome Icon BBcode package from Fireball CMS. (This package is optional and you can remove it full! My package give the same functionailty and will extend it a little bit!)

  • Version 2.0.3 Pl 2


    • Old file in previous version.
    • Remove boolval (function in php 5.5)

  • Version 2.0.3


    • Remove error with headings in toc.
    • Remove a possible index.phpindex.php

  • Ist es möglich, das Inhaltsverzeichnis zu deaktivieren? Weil das wird bei mir im Forum an einer komplett falschen stelle angezeigt...
    Oder wo liegt der Fehler?
    Screenshot: http://image.prntscr.com/image…54c5eb362fb96ffa0c4ac.png

  • Hallo, eine Frage. Wird es den BBCode auch für die Suite geben ? (wenn nicht hab ich vedammt viel Arbeit weil dieser in mindestens 2000 Beiträgen (Lexikon von VieCode) steckt..

    • Diese Frage musst du SoftCreatR stellen. Er hat die Pflege übernommen. Ich habe leider zur Zeit nicht mal ansatzweise die Zeit die BBCodes aktiv zu pflegen.

  • Wo kann ich denn ein paar Code-Beispiele sehen bzw. nachvollziehen... welcher Code bring welches Ergebnis?

  • Dieses Paket ist inkompatibel mit den folgenden, installierten Paketen: •„Font Awesome Icon BBCode“ (de.codequake.bbcode.icon)

  • Hi, habe 3 kurze Fragen:


    1. Wie bekomme ich bei den Bildunterschriften (im Blog) den kleinen Bindestrich weg? Also statt "- blablabla" soll nur "blablabla" als Bildunterschrift zu sehen sein.


    2. Wie kann ich im Blog die Bildgröße anpassen, wenn ich ein Bild mit Beschreibung einfüge? Leider taucht das nur als Code auf und nicht als Bild mit Bearbeiten/Zerrfunktion (was es normalerweise tut, ohne die Beschreibung).


    3. Wenn ich ein Bild mit Beschreibung am Anfang des Blogs einfüge, taucht auf der Artikel-Übersichtsseite des Blogs dieser Bilduntertitel noch zusätzlich zum Vorschaubild auf. Wie bekomme ich das so hin, dass in der Artikel-Übersicht nur das Bild angezeigt wird (ohne die Bildunterschrift) und wenn ich dann auf den Artikel klicke das Bild natürlich mit der Bildunterschrift zu sehen ist?


    Danke!

  • Hi Teralios, das hier zum Download verfügbare Paket lässt sich unter WBB4.0 nicht installieren (Benötigt das Paket „WoltLab Community Framework“ in Version „2.1.7“ oder höher, es ist aber nur Version „2.0.12 pl 1“ installiert.) obwohl es als dafür geeignet beworben wird. Wo/wie bitte kann ich ein passendes Paket herunterladen?

  • Hmmm, irgendwie werden mir Updates für dieses Plugin nie automatisch angeboten. Ich muss sie immer manuell laden und installieren. Bei anderen Plugins aus dem Plugin-Store habe ich damit keine Probleme. Komisch...

    • Liegt vielleicht auch daran, dass ich immer nur die letzten 1-2 Versionen beim Updaten unterstütze und man daher nach spätestens eben 2 Versionen erst den Zwischenschritt gehen muss.

    • Ich hatte 2.2.1 installiert und das Update auf 2.2.2 nicht bekommen. Mit der letzten Version war es auch bereits so. Ist aber kein Beinbruch. ;)

  • Beim Install leider eine Fehlermeldung:
    Installierte Version = 2.1.0 Pl 1 (20. Juli 2015)


    An update of package de.teralios.bbcodes from version 2.1.0 Pl 1 to 2.2.1 is not supported.


    Stacktrace:


    #0 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/system/package/PackageInstallationScheduler.class.php(518): wcf\system\package\PackageInstallationScheduler->findShortestUpdateThread('de.teralios.bbc...', Array, '2.1.0 Pl 1', '2.2.1')
    #1 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/system/package/PackageInstallationScheduler.class.php(106): wcf\system\package\PackageInstallationScheduler->updatePackage(115, '2.2.1')
    #2 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/system/package/PackageInstallationScheduler.class.php(67): wcf\system\package\PackageInstallationScheduler->tryToInstallPackage('de.teralios.bbc...', '2.2.1', true, false)
    #3 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/data/package/update/PackageUpdateAction.class.php(497): wcf\system\package\PackageInstallationScheduler->buildPackageInstallationStack(false)
    #4 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/data/package/update/PackageUpdateAction.class.php(449): wcf\data\package\update\PackageUpdateAction->createQueue('update')
    #5 [internal function]: wcf\data\package\update\PackageUpdateAction->prepareUpdate()
    #6 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/data/AbstractDatabaseObjectAction.class.php(196): call_user_func(Array)
    #7 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/action/AJAXProxyAction.class.php(77): wcf\data\AbstractDatabaseObjectAction->executeAction()
    #8 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/action/AJAXInvokeAction.class.php(96): wcf\action\AJAXProxyAction->invoke()
    #9 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/action/AbstractAction.class.php(49): wcf\action\AJAXInvokeAction->execute()
    #10 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/action/AJAXInvokeAction.class.php(63): wcf\action\AbstractAction->__run()
    #11 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/system/request/Request.class.php(58): wcf\action\AJAXInvokeAction->__run()
    #12 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
    #13 /homepages/14/d407714533/htdocs/forum-blasenkrebs-net/acp/index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)
    #14 {main}

    • Entschuldige bitte diese harte Wortwahl nun.


      1. Ich gebe hier kein Support. Dafür existiert ein Support-Forum
      2. Lese die Fehlermeldung und entsprechende Aussagen hier!

    • Version 2.2.0 manuel installieren und danach Updaten dann gehts.

    • Erst die Version Version 2.2.0 installieren, kannste hier im Store laden. Dann gehts

  • Dein BBCode beißt sich mit dem vom Sascha (Fa-icon)

    • Ehrlich Antwort? Selbst Schuld. Die Funktionalität mit Icons existiert seit Version 2.0. Seit 2.2 ist jetzt auch ein Auswahl-Dialog eingebaut. Daher ist es nicht notwendig ein weiteren BBCode für Icons zu installieren.


      Das andere Paket - ein optionales Paket für das FireBall-CMS - wird ohnehin bereits ausgeschlossen. Ich kann gerne auch noch das von Sascha ausschließen, wobei es sich nicht beißen sollte, da er anderen BBCode belegt. Einzige was vor kommt ist, dass das man nun zwei BBCodes hat, mit den man Icons einfügen kann.


      Daher, so unfreundlich es klingt: Wenn interessiert es?

    • Information:


      id: 2615e114a0c2c46af38b0f3ed2065db4e6980a83
      error message: Could not execute prepared statement: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'icon' for key 'bbcodeTag'
      error code: 23000
      sql type: wcf\system\database\MySQLDatabase
      sql error: Duplicate entry 'icon' for key 'bbcodeTag'
      sql error number: 23000
      sql version: 5.1.73-1+deb6u1
      sql query: INSERT INTO wcf1_bbcode (bbcodeTag,htmlOpen,htmlClose,allowedChildren,wysiwygIcon,className,isSourceCode,buttonLabel,originIsSystem,packageID) VALUES (?,?,?,?,?,?,?,?,?,?)
      sql query parameter 0:icon
      sql query parameter 1:
      sql query parameter 2:
      sql query parameter 3:none
      sql query parameter 4:
      sql query parameter 5:wcf\system\bbcode\IconBBCode
      sql query parameter 6:0
      sql query parameter 7:
      sql query parameter 8:1
      sql query parameter 9:64
      file: /var/customers/webs/ni418740_1/wcf/lib/system/database/statement/PreparedStatement.class.php (97)
      php version: 5.3.29
      wcf version: 2.1.6 (Typhoon)
      date: Tue, 18 Aug 2015 08:04:31 +0000
      request: /acp/index.php?install-package/&&
      referer: http://alex-fotoecke.de/acp/in…p?package-start-install/&



      Stacktrace:
      #0 /var/customers/webs/ni418740_1/wcf/lib/data/DatabaseObjectEditor.class.php(38): wcf\system\database\statement\PreparedStatement->execute(Array)
      #1 [internal function]: wcf\data\DatabaseObjectEditor::create(Array)
      #2 /var/customers/webs/ni418740_1/wcf/lib/system/package/plugin/AbstractXMLPackageInstallationPlugin.class.php(201): call_user_func(Array, Array)
      #3 /var/customers/webs/ni418740_1/wcf/lib/system/package/plugin/BBCodePackageInstallationPlugin.class.php(153): wcf\system\package\plugin\AbstractXMLPackageInstallationPlugin->import(Array, Array)
      #4 /var/customers/webs/ni418740_1/wcf/lib/system/package/plugin/AbstractXMLPackageInstallationPlugin.class.php(171): wcf\system\package\plugin\BBCodePackageInstallationPlugin->import(Array, Array)
      #5 /var/customers/webs/ni418740_1/wcf/lib/system/package/plugin/AbstractXMLPackageInstallationPlugin.class.php(67): wcf\system\package\plugin\AbstractXMLPackageInstallationPlugin->importItems(Object(DOMXPath))
      #6 /var/customers/webs/ni418740_1/wcf/lib/system/package/PackageInstallationDispatcher.class.php(571): wcf\system\package\plugin\AbstractXMLPackageInstallationPlugin->install()
      #7 /var/customers/webs/ni418740_1/wcf/lib/system/package/PackageInstallationDispatcher.class.php(139): wcf\system\package\PackageInstallationDispatcher->executePIP(Array)
      #8 /var/customers/webs/ni418740_1/wcf/lib/acp/action/InstallPackageAction.class.php(73): wcf\system\package\PackageInstallationDispatcher->install('4e31ca19')
      #9 /var/customers/webs/ni418740_1/wcf/lib/action/AbstractDialogAction.class.php(70): wcf\acp\action\InstallPackageAction->stepInstall()
      #10 /var/customers/webs/ni418740_1/wcf/lib/action/AbstractAction.class.php(49): wcf\action\AbstractDialogAction->execute()
      #11 /var/customers/webs/ni418740_1/wcf/lib/system/request/Request.class.php(58): wcf\action\AbstractAction->__run()
      #12 /var/customers/webs/ni418740_1/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
      #13 /var/customers/webs/ni418740_1/acp/index.php(10): wcf\system\request\RequestHandler->handle('gallery', true)
      #14 {main}

    • Das kommt aber nicht vom Paket von Sascha. ;) Willst du das Fireball CMS installieren? ;) Sascha belegt FA nicht icon. :)

    • Ja auch gesehen das es das von CodeQuake war, habe das CMS bereits vor deinem Installiert gehabt =)

    • Das CMS selbst ist da nicht das Problem, such da mal nach dem Code Quake Font Awesome Icon oder wie es heißt. das kannst du getrost wegwerfen. Selbst das von Sascha wäre so nicht notwendig, vor allem gibt es einen kleinen Vorteil bei meinem BBCode, zu sehen hier: http://teralios.de/community/thread/49-test/#post181 Die Icons müssen nicht nur im text stehen, sondern können auch zum Text hin ausgerichtet werden. Vorteilhaft beim Gestalten ;)

  • - Icons können über das Rebellen-Icon gesucht und eingefügt werden.


    Wie soll das funktionieren? Gibt es dazu eine Erläuterung?

    • Drauf klicken, auf Icon klicken:Voila das Icon ist da. ;)

    • Jetzt hab ich ich es. Es wurde übers ACP nicht aktualisiert. Musste die alte Version runterwerfen und die neue draufhauen. Ich dachte das wäre nur von 1.5 auf 2.1 so.

    • Version 2.0 ist ein vollständiger Bruch zu 1.5 gewesen. Ging also 1.5 auf 2.0 nicht, gehen alle folgende Updates auch nicht. Sorry. ;)

    • Sorry für den Dislike, aber von Version 2.1 auf 2.2 sollte ein Update via ACP schon möglich sein. Finde das etwas blöd geregelt. Ansonsten bin ich weiterhin vom Plugin begeistert :)

    • Moment mal: Ein Update von Version 2.1.0 und 2.1.0 Pl 1 auf Version 2.2.0 ist möglich und wurde auch in der Form getestet: https://github.com/Teralios/de…ob/master/package.xml#L41


      Solltest du jedoch noch eine Version 2.1.0 RC 1 installiert gehabt haben, war und ist natürlich kein Update möglich gewesen. Ich unterstütze offiziell nur das Update von der jeweils letzten aktuellen Version inklusive Patchlevels. Alles andere ist leider sehr intensiv beim Testen und dafür reicht die Zeit nicht.

  • Link auf Einleitungsseite gibt Fehler aus! Bitte Anpassen - Danke

  • Wird es eine Möglichkei geben auch beim Gallery BBCode eine Bildunterschrift zu nutzen?

  • Hallo, seit dem Update können User ihre Signaturen nicht mehr bearbeiten. Ich konnte es auf die BBCodes zurückführen. Nach der Deinstallation geht es wieder mit den Signaturen. Vielleicht kannst Du das noch fixe, da die BBCodes schon super sind und bei uns auch genutzt werden. Sonst muss ich leider zukünftig darauf verzichten.

  • Hallo Teralios. Ersteinmal danke für dieses tolle Plugin! Ich würde es wirklich gerne benutzen..jedoch funktioniert nur deine version 1.5.0. Bei denn dateien dadrüber gibt es mir die Fehler meldung das ich 2.1 WCF brauche .-. Gibt es auch einen weg es auf 2.0 zu installieren?

    • Leider nein, da Version 2.0.x auf dem WCF2.0 aufbaut und dort auf einigen Änderungen am BBCode-System und dem Message-System.


      Jedoch ist Version 1.5.0 äquivalent zu Version 2.0. In Version 2.0 ist nur ein BBCode dazu gekommen, ansonsten ist jedoch eine Funktion erst mal entfernt worden, die jetzt erst wieder umgesetzt wurde.

  • Hallo Teralios. Ich würde es wirklich toll finden, wenn du die einzelnen BB-Codes in einzelne Unterpakete aufsplitten könntest, um eine Auswahl treffen zu können welche man tatsächlich haben möchte :)

    • Das wird in der Form nicht passieren, da so der Pflegeaufwand für die BBCodes viel zu hoch ist. Zu dem habe ich mit bekommen, dass viele sämmtliche BBCodes installieren.

  • Ist es richtig, dass es pro Seite im Thread ein Inhaltsverzeichnis gibt ? Oder ist es auch möglich eins zu erstellen das für einen kompletten Thread ist ?

  • XATTACH CODE:
    Beim Xattach wird mir jeweils vor dem Bildtext ein " - " angezeigt. Kann der weg ?
    Mir ist auch aufgefallen, dass beim neuen Blog auf der Startseite unter dem Bild auch der BildT¨text vorkommt, kann man den dort weg machen ?
    Der Bildtext ist zentriert, ich würde diesen gerne Links ansetzen. Wie funktioniert das ?


    http://www.report.lu/blog/


    Danke

    • Weg machen kann man den Text nicht, wenn man xAttach nutzt. Das mit dem - kann man über CSS.


      Da ich gerade unterwegs bin, kann ich leider auch nicht helfen. Mögliche CSS-Anpassungen kannst du hier im Forum erfragen.

  • PRO-Contra BBCODE:
    Ich habe den BBCODE mal eingesetzt. Funktioniert sehr gut!
    http://www.report.lu/index.php…edakteure/?postID=3#post3


    Meine Frage, wie bekomme ich die Formatierung der Box und Farbe "Hintergrund" weg wo PRo & Contra drin steht ? Ich möchte dass es sich neutral in die Umgebung anpasst. Also ohne Hintergrund. (Es sollte so aussehen wie auf deiner Webseite,)


    Danke

  • Very interesting plugin. Great job. ;)

  • Hallo irgendwie stimmt da was nicht so ganz siehe Screens


    FireFox: http://up.picr.de/21616602iw.png


    Google Crome: http://up.picr.de/21616603bw.png


    Opera: http://up.picr.de/21616604sr.png


    Wenn ich das Icon anklicke lande ich hier: https://patents.justia.com/inventor/wolf-r-achterrath


    Woran liegt das wo holt er die URL her? Bin schon am suchen aber kann absolut nichts finden. Auch an anderen PC´s getestet genau das gleiche. Die Screens sind von deinem Blog und so sieht das auf meinem Forum auch aus.

    • Das ist alles richtig. Es ist ein "EasterEgg". ;) Es kommt zu zwei Tagen dazu. Und wenn du mal in mein Impressum schaust und dort, dann sollte dir vielleicht auch was auffallen. ;)

    • Der Satz verwirrt mich! Was bedeutet:"Es kommt zu zwei Tagen dazu."? Im Impressum (teralios.de) habe ich nichts Erläuterndes gefunden!
      Wie kann ich diese für mein Gefühl "deplazierte" Information in meinem Forum unterbinden? Gerne auch gegen Unkostenbeitrag! Ansonsten müsste ich CSS bemühen.

    • Es kommt genau zu zwei Tagen. Unterbinden kannst du es nicht und das hat seinen Grund.


      Wenn man sich im Impressum mein Namen ansieht und den dortigen im Link, wird man auch verstehen, warum dieser Link vorhanden ist. Und warum 2 Tage? Na, überleg mal!

    • Irgendwas mit Patents by Inventor Wolf R. Achterrath steht da. Wie dein Name auch im Impressum, das ist mir schon aufgefallen. Aber so ganz erklärt es mir doch nicht weshalb dies verlinkt wird. Ist schon irreführend, dachte hätte mir irgendwas eingefangen auf meinem Server.


      Dein Satz: Es kommt genau zu zwei Tagen. <--- Mit dem kann ich nichts anfangen was die Verlinkung betrifft. Entweder lese ich was falsch oder ich bin zu doof es zu entschlüsseln was genau es zu bedeuten hat.

    • Es gibt 2 Tage eines Menschen, die absolut fest stehen. Geburtstag und der Todestag. ;) An diesen beiden Daten wird das Rebellen-Icon eingeblendet. Es ist ein Easteregg im Gedenken an meinen Vater. Deswegen nehme ich sie auch nicht raus. Wer es tun will, kann dies gerne tun, ich werde dazu jedoch keine Hilfestellung geben. Genau so bitte ich, dass eine Lösung nicht hier öffentlich zugänglich gemacht wird.

  • Hallo bekomme beim installieren 15% diese Fehlermeldung: id: 73e474899c4645466ecc9390000839d6eaaaf344
    error message: Could not execute prepared statement: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'icon' for key 'bbcodeTag'
    error code: 23000
    sql type: wcf\system\database\MySQLDatabase
    sql error: Duplicate entry 'icon' for key 'bbcodeTag'
    sql error number: 23000
    sql version: 5.5.41-0+wheezy1-log
    sql query: INSERT INTO wcf1_bbcode (bbcodeTag,htmlOpen,htmlClose,allowedChildren,wysiwygIcon,className,isSourceCode,buttonLabel,originIsSystem,packageID) VALUES (?,?,?,?,?,?,?,?,?,?)
    sql query parameter 0:icon
    sql query parameter 1:
    sql query parameter 2:
    sql query parameter 3:none
    sql query parameter 4:
    sql query parameter 5:wcf\system\bbcode\IconBBCode
    sql query parameter 6:0
    sql query parameter 7:
    sql query parameter 8:1
    sql query parameter 9:32
    file: /var/www/web65/web/wcf/lib/system/database/statement/PreparedStatement.class.php (97)
    php version: 5.4.39-0+deb7u2
    wcf version: 2.1.2 pl 4 (Typhoon)
    date: Sat, 11 Apr 2015 20:15:59 +0000
    request: /acp/index.php?install-package/&&
    referer: http://www.report.lu/acp/index…tion-confirm/&queueID=57&
    Stacktrace:


    #0 /var/www/web65/web/wcf/lib/data/DatabaseObjectEditor.class.php(38): wcf\system\database\statement\PreparedStatement->execute(Array)
    #1 [internal function]: wcf\data\DatabaseObjectEditor::create(Array)
    #2 /var/www/web65/web/wcf/lib/system/package/plugin/AbstractXMLPackageInstallationPlugin.class.php(201): call_user_func(Array, Array)
    #3 /var/www/web65/web/wcf/lib/system/package/plugin/BBCodePackageInstallationPlugin.class.php(153): wcf\system\package\plugin\AbstractXMLPackageInstallationPlugin->import(Array, Array)
    #4 /var/www/web65/web/wcf/lib/system/package/plugin/AbstractXMLPackageInstallationPlugin.class.php(171): wcf\system\package\plugin\BBCodePackageInstallationPlugin->import(Array, Array)
    #5 /var/www/web65/web/wcf/lib/system/package/plugin/AbstractXMLPackageInstallationPlugin.class.php(67): wcf\system\package\plugin\AbstractXMLPackageInstallationPlugin->importItems(Object(DOMXPath))
    #6 /var/www/web65/web/wcf/lib/system/package/PackageInstallationDispatcher.class.php(571): wcf\system\package\plugin\AbstractXMLPackageInstallationPlugin->install()
    #7 /var/www/web65/web/wcf/lib/system/package/PackageInstallationDispatcher.class.php(139): wcf\system\package\PackageInstallationDispatcher->executePIP(Array)
    #8 /var/www/web65/web/wcf/lib/acp/action/InstallPackageAction.class.php(73): wcf\system\package\PackageInstallationDispatcher->install('a6d8468a')
    #9 /var/www/web65/web/wcf/lib/action/AbstractDialogAction.class.php(70): wcf\acp\action\InstallPackageAction->stepInstall()
    #10 /var/www/web65/web/wcf/lib/action/AbstractAction.class.php(49): wcf\action\AbstractDialogAction->execute()
    #11 /var/www/web65/web/wcf/lib/system/request/Request.class.php(58): wcf\action\AbstractAction->__run()
    #12 /var/www/web65/web/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
    #13 /var/www/web65/web/acp/index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)
    #14 {main}

    • Ja, der Fehler ist in der form bekannt, ich kann ihn aber leider nicht lokalisieren. Das Problem ist, dass es nioch einen anderen BBCode gibt, der als icon-BBCode fungiert. Ich habe diesen hier aber nie gefunden und weiß auch niocht, woher er kommt!

    • ja sehe gerade in der Liste nach dort gibt es einen icon-BBCode: class="icon icon-%s ( Könnte vom Lexikon oder dem Fireball CMS ) stammen ?

    • Lexikon hab ich geprüft, von dem kommt es nicht. Fireball CMS eigentlich auch nicht. Hab beides durch gesehen!

    • dann bleibt mir nur noch die Easylink Anwendung

    • Das könnte theoretisch sein. Du könntst in der Datenbank auch nachschauen: wcf1_bbcodes dort sollte ne packageID als feld sein und von dort kanns du in wcf1_package wcf1_packageInformation nach schauen!

  • kann man die Breite der Inhaltsbox irgendwie verändern so das sie zb. nur noch so Breit ist wie der Text der in ihr drin steht, weil momentan fühlt es ja die Ganze Seite aus

  • Footnotes at the bottom says this wcf.teralios.footnotes
    Should it not say footnotes? I'm using the default style for WBB 4.1.1

  • Ich brauche das Plugin ich nutze das WCF 2.0.12 OHNE das WBB, also nur das CMS von Quodecake und das Lexicon welcher Version muss ich dann nehmen ?


    Leider scheint das Inhaltsverzeichniss nicht Kompatible sehr schade, weil kein WBB vorhanden :(

  • Ich habe folgende Fehlermeldung:


    http://abload.de/img/fehler54u0w.jpg

    • Man sollte die Fehlermeldung auch lesen und ggf. auch hier die entsprechenden Update-Anweisungen. Mehr muss ich dazu denke ich nicht sagen.

    • I'm getting the same error, also when i search for your 2.0 package i don't find it, i only find the 1.50 version.
      I'm running WB 4.1.1

    • Unistall all my packees, before you update to 2.0.2. It's important. Some changes in the structure.

    • Yes thank you.
      The problem was that the error message read like there was a "copyright" problem, so i didn't thought that it was a file.
      It's all good now, thank you for making this

  • This keeps getting better and better. Good job. :)

  • Interessantes Plugin! Muss man die BBCodes von Hand schreiben oder gibt es dafür ein komfortables Icon? In der Beschreibung werden nur die BBCodes genannt wie man sie schreiben muss, für die meisten Anwender ist aber ein händisch geschriebener BBCode zu aufwändig. Ein Icon wäre da sehr praktisch :)

    • Es gibt einige BBCodes als Icon, jedoch nicht alle.


      In zukünftigen Versionen ist es auch angedacht etwas tiefer in den Redactor einzusteigen um Overlays anzubieten.,

    • Alles klar, danke für die Info. Werde dieses Plugin aber eh erst mit WBB 4.1 einsetzen.

  • Das bekomme ich wenn ich den Installieren möchte:
    Fatal error: Could not execute prepared statement: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'icon' for key 'bbcodeTag'

    • Dann ist bereits in BBCode installiert, der icon besetzt. Leider kann ich dagegen nichts unternehmen, ohne zu wissen, welche BBCodes installiert sind.

    • hab alle BBCodes deinstalliert und deinen dann installiert. Jetzt geht es....

    • Hättest nicht alle deinstallieren müssen, nur den, der icon nutzt. Wobei ich hier keinen finde. Bräuchte da aber ne Info, so dass ich es ausschließen kann.

  • Kommt auch noch ein Update mit den BBCodes wie hier hier beschrieben: http://teralios.de/entry/64-bb…richtig-ein/#a-1004dd091f für das WBB 4.0 ? Damit meine ich die "besseren" optische anspruchsvolleren BBCodes wie z. B. bei Pro & Contra. Optisch gefällt mir Pro & Contra bei Version 1.5 hier nicht so gut. Bei Version 2 siehts dafür sehr schick aus :)

  • Irgendwie begreife ich hier mit den Versionen gar nichts mehr. Welche Version muss ich nehmen damit diese in 4.1.1 funktioniert. In 4.1.1 setze ich das Lexikon von Viecode ein. In deren Datenbank ist das xattach mindestens 2000 mal gesetzt. Desweiteren benutze ich die Datenbank von CLS Design (EasyLink) in denen das xattach fleißig benutzt wurde. Selbstverständlich wurde das xattach hier und da auch in den ganz normalen Forenbeiträgen und im Blog benutzt. Vieleicht hilft mir jemand auf die Sprünge. Danke

    • Die Version 2.0 befindet sich in der Freischaltung. Wie lange es dauert, kann ich in diesem Fall nicht sagen, da einiges vorher noch geklärt werden muss. Im Blog stehen entsprechend die Informationen dazu!

    • OK.. ich bedanke mich