Standard avatars 2.0.2 pl 6

License Agreement
WBB-Elite.de Lizenz
Website
https://www.wbb-elite.de
Supported Versions
Burning Board 4.0 / WCF 2.0
Burning Board 4.1 / WCF 2.1

With this plugin standard avatars can be managed and used


The version 1.0. * Is for the WCF 2.0 / WBB4.0 and version 2.0. * Is designed for the WCF2.1 / WBB4.1.
With this plugin standard avatars can be added.

This can for certain groups, and only after a certain number of points that the user must be usable reach.



Version for theWSC3.0/3.1 or WSF5.0/5.1


It can be an avatar except the selected'll add the user in the registry.


Images

  • Version 2.0.2 pl 6

    Some bugfixes
  • Version 2.0.2 pl 5

    Update nur für das WCF2.1/WBB4.1
    PHP 5.6 wird vorausgesetzt

  • Version 2.0.2 pl 4

    Update nur für das WCF2.1/WBB4.1

  • Version 2.0.2 pl 3

    Update nur für das WCF2.1/WBB4.1
    Behebt den Fehler das Bilder die kleiner als 192px*192px waren beim hochladen einen Fehler auslösten.

  • Version 2.0.2 pl 2

    Update nur für das WCF2.1/WBB4.1

  • Version 2.0.2 pl 1

    Update nur für das WCF2.1/WBB4.1


    Fügt die Möglichkeit hinzu zufällige Standard Avatar auszuwählen.

  • Version 2.0.1 pl 6

    Fehlende Sprachvariablen hinzugefügt


    Update nur für das WCF2.1/WBB4.1

  • Version 2.0.1 pl 5

    Behebt den Fehler das die User keine Avatar auswählen können wenn Sie ein Geschlecht ausgewählt haben im Profil


    Update nur für das WCF2.1/WBB4.1

  • Version 1.0.1 pl 4

    Behebt den Fehler das die User keine Avatar auswählen können wenn Sie ein Geschlecht ausgewählt haben im Profil

  • Version 1.0.1 pl 3

    Fügt die auswahlmöglichkeit von Geschlechter hinzu.



    Ausserdem können ab jetzt die schon gesetzten Standard Avatare durch aktualisieren der Anzeige im ACP durch neue überschrieben werden

  • weiteres Problem: Deaktivierte Kategorien werden trotzdem im Frontend unter Standard Avatare aussuchen angezeigt.

    • Der Fehler ist in der neuen Version, die jedoch noch nicht hochgeladen ist. Behoben :)

    • hi, habe gerade mal diesen Fehler mit der 2.0.2 pl 6 getestet und kann irgendwie keine Veränderung erkennen. LG

  • Wenn man versucht nach dem Namen zu sortieren gibt es einen Fehler:

    Quote

    error message: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'filename' in 'order clause'

    • Wo genau?

    • Im ACP unter Benutzer -> Standard-Avatar -> Standard Avatare auflisten und dann auf Dateiname klicken um zu sortieren

    • konntest du das reproduzieren oder könnte dieses Problem auch durch ein anderes Plugin hervorgerufen werden (habe da so einen Verdacht, falls nicht reproduzierbar).

    • Nein, den Fehler habe ich gerade gefunden und auch behoben.

      Wird dann in der nächsten Version drinnen sein :)

    • Mit der neuen Version kann man sortieren, danke dafür :) Einzig die Sprachvariable wcf.attachment.avatarName scheint zu fehlen. LG

  • hi, finde das Plugin grundsätzlich gut aber eine Möglichkeit zum Entfernen von mehreren Bildern auf einmal wäre schon sehr wünschenswert (gerade wenn man eine tar hochgeladen hat und alles nochmal löschen muss weil Fehler :D ).

    Ich hätte noch eine Frage: Ist es richtig, dass es keine Unterkategorien gibt sondern nur Hauptkategorien?

    LG

    • muss auch hier nochmal auf meine Frage zurückkommen weil ich nämlich keine Kategorien eine Ebene tiefer schieben kann (signalisiert mir rot). Falls das normal ist, kein Problem. Falls aber nicht habe ich hier auch ein Problem. Denke aber nicht dass es überhaupt möglich ist Unterkategorien zu haben. LG

    • Nein, das ist so gewollt, das es nur eine Kategorieebenen gibt.

      Bezüglich des Löschens, ja da habe ich auch schon drüber nachgedacht, jedoch wollen bzw. brauchen dies nur wenige Leute. Daher wird das erstmal nicht kommen.

    • Schade, das wäre echt eine top Verbesserung (für mich). LG

  • Wäre schön, wenn es das Plugin auch für die Suite geben würde. Ist eine Version dafür geplant?

  • wird es auch noch für wbb suite 3.0.12 pl kommen hab es mir grade gekazft und musste feststellen das es nicht in mein forum geht ;(

  • Seit zwei/drei Tagen haben wir Probleme mit Standard Avatare Version 2.0.2 pl 5 auf WBB 4.1.17

    Einzelne Avatare, von Mitgliedern, zum Teil selbst hoch geladene, so wie auch mein Gravatar, verschwinden immer wieder.

    Anstelle von diesen erscheint dann der Avatar den neue Mitglieder bekommen wenn sie sich Registrierten.


    Komischerweise betrifft es nicht alle Mitglieder, und eben nicht nur die mit Gravatar oder selbst hochgeladenen Avataren, auch die welche wir in der Auswahl drin haben.


    Das Plugin habe ich schon lange im WBB 4.1.17 und bisher nie Probleme, aber jetzt ist es schon zweimal in 3 Tagen passiert.

    Mein Gravatar ist aktuell, nicht geändert worden.


    Woran liegt es das nun schon zweimal Avatare die man einstellt gelöscht werden und dafür den von den neu Registrierten auftaucht?

    • Das ist sehr merkwürdig.

      Wäre es möglich zugang zur Datenbank zu bekommen?


      Und ich müsste genau wissen bei welchen Personen das auftritt.
      Vermutlich werde ich jedoch jetzt nichts mehr finden, aber vielleicht doch.

    • Habe soeben eine PN geschickt

  • gibs das auch für wsc3 oder ist es kompatibel?

  • OK,
    hab's umgestellt auf PHP Version 7.0.10-nmm1s läuft und es läuft.
    Danke

  • Mit phpinfo ausgelesen alle anderen Plugin's laufen ja auch bei mir auf WBB4.1 (all-inkl.com)
    PHP Version 5.3.28-nmm7

    • Ja das ist richtig, jedoch mache ich alle meine Plugins auf die neusten PHP Version steht auch jeweils in den Beschreibungen der Version ;)

  • Parse error: syntax error, unexpected '[', expecting ')' in /www/htdocs/xxxx/xxxxx/wcf/lib/system/worker/DefaultAvatarRebuildDataWorker.class.php on line 47

  • Version 2.0.2 pl 5 Fehler beim aktualisieren der Anzeigen (Anzeige standard Avatare aktualisieren bringt Fehler)

  • Wenn ein Nutzer eine negative Zahl an Punkten aufweist, kann man für diesen keinen Avatar auswählen, da er weniger Punkte hat, als standardmäßig vorgegeben sind (0). Dies tritt dann auf, wenn man Bilder hochgeladen hat, während der Wert der Kategorie auf 0 stand. EIne Änderung des Wertes der Kategorie wirkt sich nicht auf die Avatare selbst aus, diese tauchen dann nicht in der Liste der auszuwählenden Avatare auf.

    • Man kann auch eigentlich keine minus Punkte haben.
      Deshalb ist dies auch so gewollt ;)

    • In meinem Forum haben einige Nutzer Minuspunkte nach einem Datenimport und auch nach dem mehrfachen Aufbereiten aller Daten bleiben diese bestehen. Auch wenn es nicht vorgesehen ist, wäre es definitiv möglich negative Punkte zu haben.

    • Nein, negative Punkte sollte ein Benutzer nicht haben. Ausserdem ist das gleiche mit den Benutzer rängen. Die bekommst du auch erst ab 0 Punkten ;)
      Wie willst du minus Aktivität haben?

  • Wollte die Ausführung "Standardavatar aktualisieren" anstoßen und bekam bei 42% folgende Meldung:


    PHP notice in file /var/www/html/domain.de/wcf/lib/system/worker/DefaultAvatarRebuildDataWorker.class.php (46): Trying to get property of non-object


    Stacktrace:
    #0 /var/www/html/domain.de/wcf/lib/system/worker/DefaultAvatarRebuildDataWorker.class.php(46): wcf\system\WCF::handleError(8, 'Trying to get p...', '/var/www/html/s...', 46, Array)
    #1 /var/www/html/domain.de/wcf/lib/acp/action/WorkerProxyAction.class.php(93): wcf\system\worker\DefaultAvatarRebuildDataWorker->execute()
    #2 /var/www/html/domain.de/wcf/lib/action/AbstractAction.class.php(49): wcf\acp\action\WorkerProxyAction->execute()
    #3 /var/www/html/domain.de/wcf/lib/action/AJAXInvokeAction.class.php(63): wcf\action\AbstractAction->__run()
    #4 /var/www/html/domain.de/wcf/lib/system/request/Request.class.php(58): wcf\action\AJAXInvokeAction->__run()
    #5 /var/www/html/domain.de/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
    #6 /var/www/html/domain.de/acp/index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)
    #7 {main}




    die Ausführung hängt nun bei 42%
    Eine Gruppe und ein Avatar wurde angelegt.
    Ein Standardavatar wurde zugewiesen.

  • Hallo cyberghost..


    Bin ich blind aber die Funktion zufälliger Avatar gibt's bei mir nicht ...


    Habe eine Kategorie angelegt und dort 3 Bilder drin...


    Option - Benutzer
    Dort kann ich eines auswählen oder *keine auswahl* anklicken das wars ... Hilfe ? ;)

  • Moin,
    was wurde denn mit dem letzten Update behoben/geändert?


    Beste Grüße

  • Es funktioniert soweit bestens, frage kann ich damit auch gästen Avatare zuweisen oder geht das nicht? Also nicht das sie einen aussuchen können , sondern einen der Standartmässig angezeigt wird?

  • Das Plugin ist jetzt installiert und funktioniert bestens, danke für die tolle Arbeit! :)
    Eine Frage hätte ich nur noch. Ich habe eine einzige Kategorie mit Avataren angelegt. Ist es möglich, diese Avatare direkt unten auf der Seite mit den Avatar-Optionen anzuzeigen, ohne dass man extra auf den Kategorienamen klicken muss? Im Grunde möchte ich also den Abschnitt mit der ID "selectAvatarForm" schon auf der Seite davor abrufen.

    • Leider ist dies nicht möglich. Und werde ich auch standardmäßig nicht einbauen.

    • Nicht schlimm, es hätte ja sein können, dass man es einfach selber umbauen kann. Ich habe den Link jetzt stattdessen etwas größer gesetzt, damit er mehr auffällt.


      Mir ist noch ein kleiner Fehler im Beschreibungstext aufgefallen: "Hier können sie aus zahlreichen Standard Avatare, eins für sich aussuchen." (Komma statt n)

  • Hi, ich hab 2.0.2 pl 3 auf meinem wbb 4.1 installiert. Hab als Kategorie 'jeder ausgewählt', die Benutzer Standardavatare schon zig mal aktualisiert, den cahse geleert... Der Avatar ändert sich nicht. Muss ich noch irgendwas einstellen?

    • Hast du auch in den Optionen den Standard Avatar ausgewählt?
      Und auch Avatare hochgeladen?

    • Danke, dass es unter Otionen-> Benutzer auch ncoh was zum asuwählen gibt, war mir nicht aufgefallen. Jetzt läufts.

  • Eine kleine Frage: Ich aktualisiere gerade einWBB 3.1.7. auf WBB 4.0.12 (besser spät als nie ;)). Dabei geht ja leider die Funktion verloren, Standard-Avatare zu verwenden. Wenn ich dieses Plugin kaufe und vor dem Datenimport installiere, bleiben dann die alten Avatare erhalten? Oder gibt es velleicht sonst irgendeinen Trick, wie ich sie retten kann? Wir haben über 2.000 Mitglieder, und da viele davon die vorgegebenen Avatare verwendet haben, finde ich es sehr schade, wenn sie alle auf einmal "nackt" dastehen.

    • Das kann ich dir leider so nicht fragen.
      Da müsstest du hier im Support-Forum nachfragen.
      Da der Importer nicht von mir sondern woltlab ist

    • Danke für die schnelle Antwort, dann forsche ich dort mal nach.

  • Ich kriege auch ein Fehler angezeigt, wenn ich aktualisieren möchte:


    SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IS NULL) AND (user_avatar_select.groupID IS NULL OR user_avatar_select.groupID I' at line 2


    Stacktrace:
    #0 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/data/DatabaseObjectList.class.php(199): wcf\system\database\Database->prepareStatement('SELECT\t\r\n\t\t\t\t\tu...', 1, 0)
    #1 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/data/user/avatar/select/SelectUserAvatar.class.php(157): wcf\data\DatabaseObjectList->readObjects()
    #2 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/data/user/avatar/select/SelectUserAvatar.class.php(116): wcf\data\user\avatar\select\SelectUserAvatar::getRandomDefaultAvatar(Object(wcf\data\user\User))
    #3 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/system/worker/DefaultAvatarRebuildDataWorker.class.php(45): wcf\data\user\avatar\select\SelectUserAvatar::getDefaultAvatar(Object(wcf\data\user\User))
    #4 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/acp/action/WorkerProxyAction.class.php(93): wcf\system\worker\DefaultAvatarRebuildDataWorker->execute()
    #5 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/action/AbstractAction.class.php(49): wcf\acp\action\WorkerProxyAction->execute()
    #6 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/action/AJAXInvokeAction.class.php(63): wcf\action\AbstractAction->__run()
    #7 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/system/request/Request.class.php(58): wcf\action\AJAXInvokeAction->__run()
    #8 /www/htdocs/xxxxxxxxxxxxx/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
    #9 /www/htdocs/xxxxxxxxxxxxx/acp/index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)
    #10 {main}

    • und wo finde ich die "Zufällige Standart Avantar" Einstellung?

    • Der Fehler oben kommt nur, wenn Häckchen bei "Zufällige Standard Avatar


      Mit dieser Option werden die Standard Avatare bei der Registrierung und beim aktualisieren zufällige zugewiesen"


      gesetzt ist. Ist diese deaktiviert kann ich allen Benutzer einen Bestimmten Avatar zuordnen, warum auch immer.

    • Mh, hast du Avatare hinzugefügt?
      Bevor du es aktiviert hast?

    • sicher

    • habe es deinstalliert und wieder installiert und jetzt geht es, vielleicht war ein problem mit den import meines forums

  • Option "Zufällige Standard Avatar" funktioniert nicht. Sie gibt einen Fehler aus.

  • Hey, kann es sein, dass das Plugin teilweise beim Ausführen des Buttons unter Anzeigen aktualisieren auch Gravatare überschreibt? ... Hochgeladene Avatare scheinen nicht betroffen zu sein, zumindest bei zwei Accounts wurde allerdings wie schon gesagt der Gravatar auf den Gast-Account gesetzt.


    Und die zweite Frage wäre ob mann vielleicht die Größe von 96px*96px im Avatar-Verwalten-Menü für die Standard-Avatare erzwingen könnte da es sehr unschön aussieht wenn man dort ein größeres Bild einblendet.


    Zuletzt noch: Gibt es eine Möglichkeit das "Keinen Avatar auswählen" automatisch den im ACP definierten Standardavatar aktiviert? Denn so sieht man ja zum teil wieder den alten svg-avatar.

    • Eigentlich sollte dies nicht überschrieben werden. Und das die Bilder skaliert werden, kann ich bei nächsten Update einbringe, aktuell werden diese auf 192px*192px skaliert. Leider nein, du must einmal die anzeige aktualisieren. dann werden alle überschrieben, den sonst bräuchte man die Möglichkeit auch nicht keine Avatar ;)

    • Mir geht es mehr um Personen die nachträglich dann wieder "keinen Avatar" auswählen :/

    • Könntest du das mit den Gravataren denn noch mal prüfen? Bin mir da nämlich recht sicher.

  • Hallo, kann ich damit auch Standardavatare für verschiedene Forenstile definieren? Also ein heller Forenstil erhält einen anderen Standardavatar als ein dunkler Forenstil? Danke & Grüße CCFF

  • In meiner Installation ist eine Sprachvariable abgeschnitten und zwar steht bei den Anzeigen aktualisieren nur noch "Ändert alle Standard Avatare in den im ACP ausgewählten um". Im Laguage File steht auch nicht mehr. Was macht die Aktualisierung?


    Bei den Adminrechten unter "Benutzer" finde ich dann nur den Namen der Sprachvariablen "wcf.acp.group.option.admin.user.canMangeSelectUserAvatar". Die Variable ist nicht vorhanden, aber gelöscht habe ich sie nicht und im Language File habe ich sie nicht gefunden.


    Bitte bei Gelegenheit das Language File ergänzen. Danke!

  • Ich habe das PlugIn nun auch installiert. Installation und Einrichtung hat soweit geklappt und alles funzt prima. Vielen herzlichen Dank dafür! Jetzt fände ich es noch super, wenn man als Admin ein Standardavatar einem User im Profil einstellen könnte, so wie man ihm auch eins hochladen kann. Das war im wbb2 schon so möglich und ich habe das oft fürs Team genutzt. Super fände ich es auch, wenn man in der Avatar- und Kategorieübersicht schon sehen würde, welche Benutzergruppe man zugeordnet hat und dort auch mehrere auswählen könnte, um Änderungen an Kategorie/Avatargruppe vorzunehmen. Auf jeden Fall aber auch so ein tolles PlugIn :-).

  • Bin nun auf der Übersichtsseite davon ausgegangen das in dem Paket evtl. beide Versionen vorhanden sind. Leider musste ich feststellen das unter Versionen die Info steht es sei nur noch fürs 2.1er. Es währe schön wenn ich die Version 1.0 noch bekommen könnte, da ich die 2.0 nich nutzen kann. Vielen Dank.

  • Habe eben auch gekauft. Installiert, Kategorien angelegt, Avatare hochgeladen. Im Acp sehe ich sie, aber angezeigt wird nichts.
    Im ACP unter Optionen / Benutzer / Standard Avatar ist auch nur ein einizger Punkt: Standard Avatar: (Keine Auswahl). Lässt sich auch nicht verändern. :( Es kommt auch keine Fehlermeldung.
    http://abload.de/img/standard_avatargak5z.png

    • Es muss definitiv ein Fehler in der pl5 in Verbindung mit dem 4.1.6 sein. Denn mit der pl3 scheint es zu funktionieren... Jedenfalls wird mir hier eine Auswahlmöglichkeit angezeigt, die bei der pl5 nicht vorhanden ist / war

    • So wie es aussieht sind die Avatare entweder nicht in der Gruppe gast,jeder oder registrierte Benutzer. Oder aber auch der Benutzer muss mehr als 1 aktivitatspunkt haben oder männlich oder weiblich eingetragen haben im Userprofile

    • Ich hatte 2 Kategorien, für registrierte User und eine andere Benutzergruppe. Dort jeweils noch 2 Kategorien mit männlich / weiblich (wegen unterschiedlicher Avatare.Aktivitätspunkte 0 und 10 bei der 2ten Gruppe. Nachdem ich die pl5 deinstalliert und die pl3 installiert habe wurden sie auch angezeigt. Vorher hatte ich natürlich auch Cache geleert, Anzeige aktualisiert. Kein Erfolg mit pl5, aber eben der pl3. ;)

    • mh, wäre es möglich mir das ganze mal anzusehen? Wenn ja schick mir bitte mal per Konversation Admin-Login Daten dann werde ich mir das ansehen und dann beheben, sofern es ein Fehler ist

    • PN mit Zugang ist raus ;)

  • Seit dem Update sehe ich keine Avatare mehr, im ACP sind sie drin, aber nicht im Profil, das ist etwas blöd, was kann ich tun?

    • Welche Version hast du installiert?

    • Falls du die Version Version 2.0.1 pl 3 installiert hast oder 1.0.1 pl 3 dann update auf die pl 4 bitte, wenn nicht dann wäre es nett wenn du mir per Konversation einmal Admin zugang geben könntest dann sehe ich mir das ganze mal an

    • Ok mache ich morgen, wollte grad ins Bett :)

  • Ich muss einfach mal zwischendurch ein Lob aussprechen! Hier findet wirklich toller und schneller Support von Cyberghost statt und Vorschläge werden auch berücksichtigt.
    Und nein, ich sollte das nicht im Auftrag schreiben, war mir einfach mal ein Bedürfnis.

  • Seit Update sind keine Avatere mehr zu sehen, weder Mitglieder noch Admin kann was sehen ausser den Kategorien. klickt man irgendeine Kategorie ist alles leer. Weder Aktualisieren der Standardavatare, noch Cache leere bringt etwas.

    • Oh hat das update die gelöscht?
      Ist ein neuer Avatar sichtbar wenn du ihn jetzt hinzufügst?

    • im ACP sehe ich die Avatare und auch im Forum bei der Mitgliederliste. Nur im Profi - Avatare auflisten werden nur die Kategorien gezeigt aber keine avatare. Hatte Mittags noch einen neuen hochgeladen, den ich auch nicht in der Auflistung im Profil sehe aber im ACP unter Avatare ist er drin.

    • Könnte ich envetuell zugriff auf das Forum bekommen um zu sehen wo etwas falsch eingestellt ist ?
      Falls ja schick mir das bitt per Konversation :)

    • ok, hast eine Nachricht (Konversation). Danke das da mal schauen willst.

    • Danke für die schnelle Hilfe und das neue Update. Es klappt nun alles bestens.

Customers Who Bought This File Also Bought