Tooltips on Top 1.0.2

License Agreement
GNU Lesser General Public License (LGPL)
Website
http://kittmedia.com
Supported Versions
Burning Board 4.0 / WCF 2.0
Burning Board 4.1 / WCF 2.1

The plugin “Tooltips on Top” moves every tooltip from the bottom of the hovered element to the top of this element.

The plugin “Tooltips on Top” moves every tooltip from the bottom of the hovered element to the top of this element so that the tooltip does not overlap any subsequent content and even does not get overlapped by the mouse.
  • Version 1.0.2

    – Fixed wrong calculation
  • Version 1.0.1

  • I'm very much a newbie, and was accustomed to the typical installation instructions that were provided on vBulletin. Can you please tell me how to install this, or what directory to install this to? Thanks.

    • Just download the package and upload it in your ACP under System -> Packages -> Install Package and you’re done. :)

    • Again, I'm an idiot who is only familiar with vB, so please forgive me. Which files get uploaded? I unzipped the download and it looks like there are three files. Should I not have unzipped it?

    • Don’t unzip anything. Just upload the file exactly as downloaded before.

    • Thank you! Obviously, this is *very* different from vB 3.8!

    • I can't believe how easy that was! And it works great! Thank you, Matthias!

  • Gibt es so was auch für den Editor?

  • An update of package com.kittmedia.wcf.tooltipsontop from version 1.0.1 to 1.0.2 is not supported.


    Stacktrace:


    #0 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/system/package/PackageInstallationScheduler.class.php(518): wcf\system\package\PackageInstallationScheduler->findShortestUpdateThread('com.kittmedia.w...', Array, '1.0.1', '1.0.2')
    #1 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/system/package/PackageInstallationScheduler.class.php(106): wcf\system\package\PackageInstallationScheduler->updatePackage('119', '1.0.2')
    #2 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/system/package/PackageInstallationScheduler.class.php(67): wcf\system\package\PackageInstallationScheduler->tryToInstallPackage('com.kittmedia.w...', '1.0.2', true, false)
    #3 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/data/package/update/PackageUpdateAction.class.php(497): wcf\system\package\PackageInstallationScheduler->buildPackageInstallationStack(false)
    #4 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/data/package/update/PackageUpdateAction.class.php(449): wcf\data\package\update\PackageUpdateAction->createQueue('update')
    #5 [internal function]: wcf\data\package\update\PackageUpdateAction->prepareUpdate()
    #6 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/data/AbstractDatabaseObjectAction.class.php(196): call_user_func(Array)
    #7 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/action/AJAXProxyAction.class.php(77): wcf\data\AbstractDatabaseObjectAction->executeAction()
    #8 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/action/AJAXInvokeAction.class.php(96): wcf\action\AJAXProxyAction->invoke()
    #9 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/action/AbstractAction.class.php(49): wcf\action\AJAXInvokeAction->execute()
    #10 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/action/AJAXInvokeAction.class.php(63): wcf\action\AbstractAction->__run()
    #11 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/system/request/Request.class.php(58): wcf\action\AJAXInvokeAction->__run()
    #12 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
    #13 /var/www/vhosts/ns3220979.ip-37-59-6.eu/httpdocs/acp/index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)
    #14 {main}


    hat jemand den gleichen Fehler beim Updaten?

    • wenn ja einfach Paket entfernen und manuel das neuste Installieren funzt super!

    • Habe die Update-Anweisungen vergessen. Ist mir heute morgen auch aufgefallen, wird heute Abend korrigiert. :)

      Like 2
    • Verstehe eure likes nicht macht ihr euch lächerlich oder wollt ihr euch profilieren
      das Tool ist kostenlos und er gibt sich immer mühe macht es besser oder gibt eure Kommentare ab nur ein minus ohne warum wieso ist ärmlich

      Like 3
    • Einfach nicht drüber aufregen. Bringt nichts. ;)

      Like 2
    • solche deppen gibt es immer!

  • Tolles Plugin, danke dafür !

  • Perfekt ein muss für jeden dazu kostenlos Daumen Hoch

  • Die kleinen Dinge sind oft sehr nützlich. Ich bin auch der Meinung, dass das als Standard eingebaut werden sollte. ;) Unter 4.0 hatte ich Probleme, da flickerte der TT. Unter 4.1.2 funktioniert es prima, vielen Dank! ;)

  • geht der Spaß auch mit 4.1?

    • Selbstverständlich. :)

    • gut steht ja rechts nur BB 4.0 WCF 2.0, deswegen fragt man da lieber, aber das Plugin ist echt sinnvoll wäre toll wenn das der User für sich selbst einstellen könnte (keine ahnung, da ich das WBB noch nicht habe, und es dazu keine ausreichenden shots gibt um zu zeigen ob das ne acp oder ucp einstellung ist) und das Plugin hier im Woltlab forum genutzt werden könnte, ich hätte beihnahe versehentlich deswegen nen offscreen beitrag gemeldet, da die buttons erst bei hover übern beitrag kommen und eben unten sind...

  • maybe worth recommending for the core version?

    • I already suggested it before creating it but it was rejected.

      Like 2
    • Too bad that such small nice things aren't added to the core.

    • true this, I mean I almost accidentially reported a post which I thought being offscreen...

  • Love this. It's the little things that add up. Nicely done. :)