WoltLab Cloud Only One Thread 1.2.0

License Agreement
GNU Lesser General Public License (LGPL)
Supported Versions
Burning Board 4.1 / WCF 2.1
WoltLab Suite 3.0
WoltLab Suite 3.1
WoltLab Suite 5.2

With this plugin can you prevent the creation of more than one thread in the same forum by one user.

With this plugin can you prevent the creation of more than one thread in the same forum by one user. If the user already have a thread the user will be noticed about this circumstance throw a error message.



Versions


WCF 2.1 / WBB 4.1 WSC 3.0 WSC 3.1
Version Branch 1.0.x 1.1.x 1.2.x
Latest Version 1.0.6 pl 1 1.1.0 RC 1 1.2.0

Images

  • Version 1.2.0

    Added support for WoltLab Suite Forum 5.1

  • Version 1.1.0 RC 1

    Support for WSC 3.0
  • Version 1.0.6 pl 1

    Fixed issue if daysPruneForNextThread was set to 0

  • Version 1.0.6

    Time setting now works correctly
  • Version 1.0.5

    Umgeht ein potenzielles Problem mit der Verlinkung auf existierende Themen.

  • Version 1.0.4

    • Excluded next WCF major version
  • Version 1.0.3

    • Optional kann nun sobald die Themen eines Benutzers als erledigt oder geschlossen markiert wurden, wieder ein Thema von dem User erstellt werden
  • Version 1.0.2 pl 1

    • Behebt einen Fehler mit der Verlinkung auf existierende Themen
  • Version 1.0.2


    • If only one thread by one user exists it is now linked to the exception
    • optional you can now choose an interval when a user can start a new thread

  • Version 1.0.1

    Verhindert nun auch die Erstellung eines Themas bei einer Manipulation des Formulars.

  • Planst du ein Update für 5.2.2?

    Wäre toll ...

    • Ich muss mich verbessern, klappt doch, sorry ... :D

  • Geht das auch für Beiträge?.

    • Dafür müsste ein separates Plugin entwickelt werden.

      Like 1
    • Ah ok, schade, wäre nice

  • Hey, ist dieses Plugin auch in 3.1 lauffähig? Habe das immer sehr gern genutzt :)

    • Hallo,

      ja dieses Plugin sollte grundsätzlich auch in 3.1 lauffähig sein. Eine entsprechende Anpassung ist für Ende Februar geplant, da ich aktuell Klausurphase hab.

    • großartig, vielen Dank!

    • Ist mittlerweile verfügbar :)

      Like 1
    • Kann man die "Fehlermeldung" nicht in eine schöne Error-Box packen? :D

    • Das kommt auf deinen Stil an, wie Fehlermeldungen generell dargestellt werden ;)

  • Danke. :)

  • Bei mir kommt folgende Meldung wenn ich das Paket installieren möchte:
    "Benötigt das Paket „WoltLab Community Framework“ in Version „3.0.0 Alpha 1“ oder höher, es ist aber nur Version „2.1.12“ installiert."
    Dachte das Plugin ist auch für Burning Board 4.1 / WCF 2.1 geeignet?

    • Ist es auch, wenn du die Beschreibung bis zum Ende gelesen hättest, hättest du gesehen das nur die Versionsreihe 1.0.x für WCF2.1 ist.


      Du musst also auf Versionen klicken und dann die Version 1.0.6 pl 1 herunterladen für dein WCF2.1.

    • Ah, danke. Da war ich etwa blind. Entschuldigung aber ich finde das neue Layout von WSC3 einfach nur unübersichtlich, finde auch die neue Plugin Übersicht grausig. Aber dafür kannst du ja nix :)
      edit:
      Okay, ich hab jetzt wirklich alles angeklickt und gesucht, ich finde nix wo man die entsprechenden Version auswählen und runter laden kann. Unten ist ja nur eine Tabelle mit der Auflistung der Versionen die ja nicht anklickbar ist.

    • Du musst den Reiter "Versionen" (du bist aktuell wenn du das hier liest im Reiter "Kommentare") anklicken und dann auf den Namen der Version für den Download.

    • Ach in der Version-Übersicht direkt. *kopf->Tisch* Ok alles, klar!

  • Bekomme Fehler bei der Installation in der WoltLab Suite 3.0


    Dieses Paket ist inkompatibel mit den folgenden, installierten Paketen:
    „WoltLab Suite Forum (Burning Board)“ (com.woltlab.wbb)
    „WoltLab Suite Core“ (com.woltlab.wcf)

    • Wie schon in der Konversation geschrieben nur 1.1.x ist lauffähig im WSC 3.

  • Bei mir scheint dieses Plugin leider nicht zu funktionieren. Ich habe ein Forum so eingestellt, dass man dort nur ein Thema schreiben darf. Die Forenberechtigungen sind auch richtig eingestellt. >Kann mehr als ein Thema trotz „Nur ein Thema“ erstellen< wurde verweigert und trotzdem kann der User zwei Beiträge im selben Forum schreiben. Benutzergruppe "Jeder" und "Gäste" wurde von mir beachtet.

    • Das hängt mit dem letzten Update zusammen. Zwischenzeitlich kannst du als Workaround die Option `Zeitraum für ein neues Thema` auf einen hohen Wert stellen und es sollte funktionieren.

    • Vielen Dank für deine Antwort Fabii. Ein Update, welches den Fehler behebt, ist aber geplant oder? :)

    • Ja ist geplant, kann nur nicht sagen wann ich dazu komme. (Ob diese oder erst nächste Woche)

    • Puh... habe schon "dieses oder erst nächstes JAHR" gelesen :) Ne, kein Stress... kann auch noch ein bisschen warten.

  • Vorschlag: Auch auf Kategorien anwendbar und es kann innerhalb einer Kategorie nur 1 Thema jedes Nutzers existieren. Also muss er sich auch zwischen den Foren entscheiden.

    • Wird es von mir so nicht geben.

  • Super Plugin, tut was es soll :thumbsup:

  • Könnte man es auch so lösen, das ein weiteres Thema möglich ist, wenn das andere geschlossen oder als erledigt markiert wurde?

    • Bei geschlossen aufjedenfall, bei erledigt muss Ich mal schauen.

    • Das wäre großartig und genau das, was ich suche!

    • Beides ist möglich und wird als optionale Funktionen eingebaut.

    • Vielen Dank!

  • Bei mir kommt das hier Sie haben in diesem Forum bereits mehrere Themen erstellt, antworten Sie daher auf diese.

    • Ist auch korrekt so, wenn du mehrere Themen in dem Forum hast gibt es kein eindeutiges Thema weshalb hier kein Link gesetzt wird ;)

    • aber es war nur eins habs gelöscht und nun kann ich ein Thema erstellen

    • Das kann Ich so nicht reproduzieren.

    • So hab nun mal das neue Paket installiert ganz neu nicht geupdatet und auch hier das selbe obwohl es hier wirklich nur ein Thema von einem User gibt. Komisch oder muss man unter Anzeige aktualiesieren etwas machen ?

    • Dann bitte Ich um einen Link zum entsprechenden Forum via Konversation.

  • so weit so gut aber wo ist das Thema das ich erstellt habe kann man dazu nicht ein Link setzen irgendwie ? Die User suchen sich nen Wolf :-)

    • Ist in der nächsten Version bereits möglich.

      Like 1
  • Ein Beitrag pro Thema wäre auch ne feine Sache :-)

  • Gute Idee. ;)
    Wird die Beschränkung automatisch aufgehoben wenn zb das Thema von einem User gelöscht wird?

  • Gute Sache! Sehr gut! Eine Frage konnte ich auf die Schnelle nicht klären: Wo kann ich die Einschränkung für einzelne Benutzer wieder aufheben?

    • Forum bearbeiten -> Berechtigungen -> Recht "Kann mehr als ein Thema trotz „Nur ein Thema“ erstellen" vergeben.

    • Super, Danke!!! Beim nächsten Update vielleicht an den kleinen Schreibfehler ("totz" statt "trotz") denken ...

    • Oh gar nicht aufgefallen, klar wird natürlich geändert.

  • Nimmst du vllt. Plugin wünsche entgegen?

  • Worüber wird die Ausnahme von dieser Einschränkung gesteuert? Benutzergruppenrecht?

    • Ja über die ACL Rechte, die man bei den Forenberechtigungen einstellen kann.