Google Analytics Integration 1.0.4 pl 1

Lizenzbestimmungen
Kostenlose Plugins
Website
https://www.mysterycode.de/
Unterstützte Versionen
Burning Board 4.0 / WCF 2.0
Burning Board 4.1 / WCF 2.1
WoltLab Suite 3.0
WoltLab Suite 3.1

Einfache Integration von Google Analytics

Dieses Plugin verhindert unnötiges Code-Chaos im "Footer-Code".


Angegeben werden muss nach der Installation nur die Tracking ID. Optional kann ausgewählt werden, ob die IPs anonymisiert werden, oder nicht.
Abschließend muss die Integration in den Modulen (User) aktiviert werden.


Don't forget to add the Google Analytics section to your privacy policy!


https://www.datenschutzbeauftr…nschutzkonform-einsetzen/


Tracking can be disabled by gaOptout();

  • Version 1.0.4 pl 1

    - Fehler beim Setzen des Cookies in WSC 3.0 behoben
  • Version 1.0.4


    • Anpassungen an die DSGVO
    • gaOptout(); deaktiviert Google Analytics für die jeweilige Cookie-Domain; die Methode steht global zur Verfügung

  • Version 1.0.3


    • Kompatibilität zu WSC 3.1
    • Gruppenrecht Benutzer > Benutzerprofil > Google Analytics für diese Benutzergruppe deaktivieren

  • Version 1.0.2

    Version für WSC 3.0
  • Version 1.0.1

  • Update gestern durchgeführt (30.04.) und führt zu kritischem Fehler in Firefox. Chrome nicht betroffen.

  • Die neuste Version verursacht folgendne Fehler für User und Suchroboter:


  • Irgendwie ist das "Template" nicht angelegt worden bei der Installation.

    Ich habe die Wbb 5.1.1 ...


    Gibt es dazu ein Patch?

    Zumindest wird somit keine Frontend-Ausgabe möglich.

  • Bekomme folgende Fehlermeldung:

    Code
    1. Die Installations-Anweisungen geben für das Package Installation Plugin „option“ die Datei „“ an, diese ist jedoch nicht im Archiv enthalten. Mögliche Ursachen:
    2. Die Datei wurde dem Archiv nicht hinzugefügt
    3. Die Datei existiert, jedoch sind der Dateiname und die Angabe in den Anweisungen abweichend (Tippfehler)

    WoltLab Burning Board 4.1

  • Woran kann es liegen wenn ich in den Modulen das Plugin nicht finde?

    • das ist nicht unter "Module" sonder unter "Allgemein", ... runterscrollen

    • Die Modulsteuerung wurde mit 1.0.3 entfernt und es ist nun ausschlaggebend, dass die Option Tracking-ID (ACP-Suche und so) gefüllt ist.

  • Auch für das kommende WSC3.1 kompatibel?

  • Irgendwie scheint das Ding nicht mehr richtig zu funktionieren. Im "Panel" von Google zeigt er mir keine Daten mehr an. Ist das so gewollt?

  • Kann man mit dem Plugin auch User excluden?
    Bei uns aendern sich die IPs zu oft sodass sich das ueber Analytics schlecht realisieren laesst. Ich wuerde also gern alle Admins + Moderatoren excluden.

  • Danke!

    Funktioniert uner WSC und einfache Installation/Konfiguration

  • Wo füge ich den die Tracking ID ein?

  • Funktioniert irgendwie nicht, hab das WSC 3.0 :(
    Ich hab alles installiert, Tracking-ID eingetragen, Cache sogar geleert... nichts.


    Trage ich den von Google gegebenen Script aber in den Footer Code ein, dann klappt es auf Anhieb.

  • Lässt sich nicht installieren - Forum ist frisch aufgesetzt bisher noch keine anderen Plugins drin.Wie fixe ich nun diesen Fehler?Auch umbenennen der Datei hat leider nichts gebracht.


    Die Installations-Anweisungen geben für das Package Installation Plugin „option“ die Datei „“ an, diese ist jedoch nicht im Archiv enthalten. Mögliche Ursachen:


    Die Datei wurde dem Archiv nicht hinzugefügt
    Die Datei existiert, jedoch sind der Dateiname und die Angabe in den Anweisungen abweichend (Tippfehler)

  • Es gibt leider keinen externen Zugang zu diesem Server.
    Gerne kann ich aber jegliche Schritte ausführen und Auskünfte geben.
    Bin selbst Programmierer und der Serveradmin, von daher sollte das kein Problem sein.


    Ab Sonntag habe ich wieder Zeit.
    VG

    • Führe nach der Deinstallation mal folgende Abfrage aus: SELECT * FROM `wcf1_template_listener` WHERE `name` LIKE 'googleAnalytics'
      Diese sollte kein Ergebnis liefern, ansonsten die entsprechende Zeile löschen und den Cache (manuell) leeren. Welche WCF-Version nutzt du eigentlich?
      Sollte das nicht helfen, wird die Konstante irgendwo verwendet, wo sie vom Plugin selbst nicht eingesetzt wird.

  • Fehler beim Deinstallieren. Wenn ich dieses Plugin (Suite 3.0) deinstalliere, dann ist die Hauptseite danach nicht mehr aufrufbar.
    Im Log steht dann Folgendes: Use of undefined constant GOOGLE_ANALYTICS_ENABLE - assumed 'GOOGLE_ANALYTICS_ENABLE'
    Erst wenn ich das Modul wieder installiere läuft die Seite wieder. Ich bin jetzt von diesem Tool abhängig.


    Bitte um Lösungsansätze. Cache, etc. habe ich selbstverständlich gelöscht, das brachte nichts.

  • Funktioniert super!

  • Bekomme für das WBB 4.1 leider einen Fehler... "Information:
    id: a417a184430b45dbd40fa5f1e3e717cf41541a38
    error message: Can't overwrite unknown tables 'wcf1_page', 'wcf1_page_content'
    error code: 0
    file: /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/system/package/plugin/SQLPackageInstallationPlugin.class.php (74)
    php version: 7.0.10-nmm1
    wcf version: 2.1.12 (Typhoon)
    date: Thu, 29 Dec 2016 11:31:44 +0000
    request: /acp/index.php?install-package/&&
    referer: http://apfelrunde.de/acp/index…-install/&action=install&
    Stacktrace:
    #0 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/system/package/plugin/AbstractPackageInstallationPlugin.class.php(72): wcf\system\package\plugin\SQLPackageInstallationPlugin->install()
    #1 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/system/package/PackageInstallationDispatcher.class.php(571): wcf\system\package\plugin\AbstractPackageInstallationPlugin->update()
    #2 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/system/package/PackageInstallationDispatcher.class.php(139): wcf\system\package\PackageInstallationDispatcher->executePIP(Array)
    #3 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/acp/action/InstallPackageAction.class.php(73): wcf\system\package\PackageInstallationDispatcher->install('298c399f')
    #4 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/action/AbstractDialogAction.class.php(70): wcf\acp\action\InstallPackageAction->stepInstall()
    #5 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/action/AbstractAction.class.php(49): wcf\action\AbstractDialogAction->execute()
    #6 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/system/request/Request.class.php(58): wcf\action\AbstractAction->__run()
    #7 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
    #8 /www/htdocs/w0150797/apfelrunde/wbb4/_wbb/acp/index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)
    #9 {main}"

    • Der Fehler hat mit meinem Plugin nichts zu tun. Abgesehen davon ist mir der nur beim Upgrade auf WSC 3.0 bekannt.

    • Hmmm naja dann warte ich auf die Final von WSC 3.0, auf meiner Test-Seite läuft es.

  • Die neue Version kann anscheinend 3.0 ab, aber davon steht nichts im Beitrag selbst?

  • Muss ich nur den Tracking Code eintragen und sonst nichts machen ?