Teamspeak³ Server (Viewer/Base) 1.1.0 pl 1

License Agreement
WebExpanded Lizenz
Website
http://webexpanded.de
Supported Versions
WoltLab Suite 3.0
WoltLab Suite 3.1

Base for the Teamspeak Plugin Package. Includes Teamspeak viewer


Teamspeak³ Server Plugin Package


This plugin includes the base version of our Teamspeak³ Server Plugin Package.

This plugin makes it possible to show the TS³ server status, the current clients (and more) in your WSC.


Individual expendable

You can expand the basis version with our comming packages!

More information will come soon with our first expension.


Various settings

With the range of settings in the ACP you can customize the Teamspeak³ viewer just as you like.

You can show/hide different contents with a few clicks in the ACP: Configuration -> Options ->Teamspeak³ Plugin Package

With just one click you can show/hide current clients for example

In Content -> CMS -> Boxes -> TS Viewer you can select between two positions for the viewer.

In Pages you even can show or hide the viewer on different pages.


Integrated cache function

Now we use the cache system of the WSC, to reduce the server requests. The data is saved for a few seconds.


Userlegend

In the online legend, the users are linked to their WSC account - if the user named as well as in the WSC and in TS³.



If no TSDNS is set and the option "Show IP-address" is deactivated the viewer won't show any IP or DNS.


Images

  • Version 1.1.0 pl 1

    Fix 'virtualserver_status' Error

    - Add EventHandler in cache class

  • Version 1.1.0

    WSC 3.1 Support
  • Version 1.0.6

    - optimization for next extensions

  • Version 1.0.5 pl 2

    - Add teamspeak server password for "join button"

  • Version 1.0.5 pl 1

    • Added correctly Error Messages

  • Version 1.0.5

    • Now the cache time can be defined. (default value is 20 - in seconds)
    • You're be able now to define a title to be viewed as a header in the viewer/box.
      • the following placeholders are possible: %servername%, %clients%, %maxclients%
    • You're also be able to view the viewer 'In the content area above'
    • It have been different events integrated in the templates. (only for later extensions)

  • Version 1.0.2

    • Error fixed

  • Ich habe wegen des Plugins für servergrp und channelgrp, den ForumNamen in der Beschreibung der TS3 users kann man diese Abfragen statt den Forumsnamen mit dem Client namen zu vergleichen ?


    wäre es auch möglich sowas wie das

    Userpanel

    zu hinzuzufügen?

  • Hallo,

    seid ein update vom woltlab funzt der ts viewer nicht mehr gut.

    mal zeigt er an mal nicht und verlangt "Verbindung zum Server Query konnte nicht aufgebaut werden." was garnicht sein kann alle daten sind richtig wie gesagt seid den update geht er nur wenn er lust hat.

    warum ist das so?

    MFG Mettty

  • Hallo,


    Ich habe ein Problem, das der Viewer nicht meinen TS von meinem 2 Server anzeigen will. Auf dem gleichen Server macht er das ohne Probleme, aber wenn ich vom anderen Server den TS anzeigen lassen will nicht.


    Hab ich irgendwas vergessen? Ports sindf in der Firewall freigegeben, so wie die IP´s in der Whitzelist vom TS....


    Ich hoffe ihr könnt mir da helfen...


    MfG

    • Was genau gibt er denn für ne Fehlermeldung?

    • Sorry, das ich jetzt erst Antworte, war leider auf Montage.

      Hier die Meldungen vom Log:


      <<<<<<<<f3462ecb60e103182fc16a7071e55695be0b54cc<<<<

      Thu, 21 Mar 2019 13:16:12 +0000

      Message: array index 'channelList' does not exist in cache resource

      PHP version: 7.3.3

      WoltLab Suite version: 3.1.6

      Request URI: /index.php?teamspeak-viewer/

      Referrer: https://www.xxxxxxxxxxxxxxx.de/

      User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

      Peak Memory Usage: 5826312/134217728

      ======

      Error Class: wcf\system\exception\SystemException

      Error Message: array index 'channelList' does not exist in cache resource

      Error Code: 0

      File: /var/www/vhosts/xxxxxxxxxxxx.de/httpdocs/lib/system/cache/builder/AbstractCacheBuilder.class.php (47)

      Extra Information: -

      Stack Trace: [{"file":"\/var\/www\/vhosts\/xxxxxxxxxxxx.de\/httpdocs\/lib\/page\/TeamspeakViewerPage.class.php","line":34,"function":"getData","class":"wcf\\system\\cache\\builder\\AbstractCacheBuilder","type":"->","args":[[],"channelList"]},{"file":"\/var\/www\/vhosts\/xxxxxxxxxxxx.de\/httpdocs\/lib\/page\/AbstractPage.class.php","line":291,"function":"readData","class":"wcf\\page\\TeamspeakViewerPage","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxxxxx.de\/httpdocs\/lib\/page\/AbstractPage.class.php","line":114,"function":"show","class":"wcf\\page\\AbstractPage","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxxxxx.de\/httpdocs\/lib\/system\/request\/Request.class.php","line":83,"function":"__run","class":"wcf\\page\\AbstractPage","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxxxxx.de\/httpdocs\/lib\/system\/request\/RequestHandler.class.php","line":96,"function":"execute","class":"wcf\\system\\request\\Request","type":"->","args":[]},{"file":"\/var\/www\/vhosts\/xxxxxxxxxxxx.de\/httpdocs\/index.php","line":9,"function":"handle","class":"wcf\\system\\request\\RequestHandler","type":"->","args":["wcf"]}]

      <<<<


      Hier die von der Seite:


      Ein Fehler ist aufgetreten


      Interner Fehlercode: f3462ecb60e103182fc16a7071e55695be0b54cc


      Was ist passiert?


      Leider ist es bei der Verarbeitung zu einem Fehler gekommen und die Ausführung wurde abgebrochen. Falls möglich, leiten Sie bitte den oben stehenden Fehlercode an den Administrator weiter.




      Administratoren können die vollständige Fehlermeldung mit Hilfe dieses Codes in der Administrationsoberfläche unter „Protokoll » Fehler“ einsehen. Zusätzlich wurden die Informationen in die Protokolldatei */log/2019-03-21.txt geschrieben und können beispielsweise mit Hilfe eines FTP-Programms abgerufen werden.




      Hinweis: Der Fehlercode wird zufällig generiert, erlaubt keinen Rückschluss auf die Ursache und ist daher für Dritte nutzlos.


      System Information


      PHP Version:


      7.3.3


      WoltLab Suite Core:


      3.1.6


      Peak Memory Usage:


      5.556/128 MiB


      Request URI:


      /index.php?teamspeak-viewer/


      Referrer:


      https://www.xxxxxxxxxxxx.de/


      User Agent:


      Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0


      Error


      Error Type:


      wcf\system\exception\SystemException


      Error Message:


      array index 'channelList' does not exist in cache resource


      File:


      */lib/system/cache/builder/AbstractCacheBuilder.class.php (47)


      Stack Trace:

      #0 */lib/page/TeamspeakViewerPage.class.php (34):

      wcf\system\cache\builder\AbstractCacheBuilder->getData([ ], 'channelList')

      #1 */lib/page/AbstractPage.class.php (291):

      wcf\page\TeamspeakViewerPage->readData()

      #2 */lib/page/AbstractPage.class.php (114):

      wcf\page\AbstractPage->show()

      #3 */lib/system/request/Request.class.php (83):

      wcf\page\AbstractPage->__run()

      #4 */lib/system/request/RequestHandler.class.php (96):

      wcf\system\request\Request->execute()

      #5 */index.php (9):

      wcf\system\request\RequestHandler->handle('wcf')

    • Gehe bitte sicher das der serveradmin query auch die nötigen Rechte hat.

  • Hallo,

    wollte mal nachfragen ob das normal ist, dass der Viewer in den Einstellungen: "Allgemein" & "Privatsphäre" & ein paar andere, nicht angezeigt wird. Sieht dann so aus: http://prntscr.com/m1q472

    Auf anderen Seiten funktioniert's wunderbar :)


    MfG

  • Hallo,

    habe alle Daten exakt angegeben und auch einen Querry erstellt, aber kriege keine Ansicht.


    Verbindung zum Teamspeak³ Server konnte nicht aufgebaut werden.

  • Guten Morgen,


    aktuell haben wir ein Problem mit dem Plugin.

    Unser TS Server ist gemietet und wird wenn keiner drauf ist in einen StandBy Modus versetzt.

    Ist das der Fall zeigt das Plugin nicht offline sondern eine Fehlermeldung.

    Ist der Server Aktiv funktioniert das Plugin einwandfrei.


  • Moin,


    habe genau das selbe (oder ähnliche) Problem wir IDarky...


    Hab alles an login daten eingegeben. Aber das Plugin kann keine Verbindung herstellen...

  • Die Box zeigt folgenden Fehler an: Verbindung zum Teamspeak³ Server konnte nicht aufgebaut werden.

    Nutze Demo Version von Woltlab Suite

    Habe Query Daten eingegeben.

    (kann mich mit gleichen Daten in YaTQA einloggen)


    Finde den Fehler nicht.

  • Hallo,

    erstmal vielen Dank für das tolle Plugin :D


    Ich hätte da ein kleines Problem mit dem "Jetzt verbinden"-Button, ich habe bei "Alternativer Teamspeak DNS" meine Serveradresse eingetragen und bei "Teamspeak³ IP-Adresse" einfach localhost. Der Button nutzt leider nur nicht die Serveradresse sondern die IP-Adresse. Ist das so gewollt und besteht dich möglich kein dies so zu ändern, dass wenn eine Serveradresse gesetzt ist, der Button diese nutzt?


    MfG

    Titus Kirch

  • Bei mir werden keine user mehr angezeigt, die Verbunden sind auf dem Teamspeak. ( seit dem letzten update )

    • Hat der Benutzer die benötigten rechte um User zu sehen?

    • Heya

      ja klar, ging ja vorher auch alles. das ist ja das komische.

      Habe nun das andere plugin installiert wo man alle channels sieht usw. Da sehe ich es so wie es sein sollte ( clients und channels ).

    • mein Paket zeigt lediglich die Clients an. Und dann auch nur, wenn es nicht in der Sidebar angezeigt wird.

    • Hi

      ja dann kann man nichts machen, dann deinstalle ich es wieder, bei mir funktioniert es nicht so wie es soll ( früher ging es einwandfrei, an mein system wurde nicht geändert, außer forum updates eingespielt und dein update )

      cya

      Betaman

    • Ich finde es dennoch sehr merkwürdig. Der Rest wird aber angezeigt?

  • Ich bekomm immer die Nachricht das er sich nicht auf meinen Ts3 verbinden kann was aber ansich gehen sollte

    --> Verbindung zum Teamspeak³ Server konnte nicht aufgebaut werden.


    Die IP,Query Daten sind alle korrekt eingetragen und funktionieren auch weil über den selben Query benutzer auch ein Ts3 Rankingsystem läuft

    • ps, scheine den selben fehler zu haben wie der kommentar unter mir von danvanmoll



      Error Type:

      wcf\system\exception\SystemException




      Error Message:

      array index 'channelList' does not exist in cache resource




      File:

      */lib/system/cache/builder/AbstractCacheBuilder.class.php (47)

    • Kann mir vielleicht jemand bitte helfen? :/

    • Gehe sicher das die Daten richtig sind, die IP des Webserver in der Whitelist eingetragen ist und natürlich das er online ist. :)

  • Das Plugin lief wunderbar, aber aus heiterem Himmel kann keine Verbindung zum TS Server mehr hergestellt werden. Wenn ich auf die TS Übersicht gehe, bekomme ich folgende Fehlermeldung:


  • Das Plugin funktioniert einwandfrei - vielen Dank! Allerdings werden im TS Viewer (bei uns http://rasselbande-dayz.com/index.php?teamspeak-viewer/) alle Benutzer angezeigt, also auch solche, die sich in Channels befinden, die sie eigentlich verbergen sollten. Ich vermute, das hat mit den Recht des Query Users zu tun? Hat jemand einen Tipp, wie ich die Rechte senken kann?

    • Wurde behoben. Der Query User muss mit einer Identität angelegt werden, die keine Admin Rechte hat.

  • Warum zeigt er mir nur "Verbindung zum Teamspeak³ Server konnte nicht aufgebaut werden." obwohl der Link definitiv stimmt :-(

  • Leider bringt dieser Viewer auch bei mir oft die Meldung "Verbindung zum Teamspeak³ Server konnte nicht aufgebaut werden.

    Der Teamspeak und der Webserver laufen auf dem selben Server.

    Der Webserver und das Forum laufen aber immmer problemlos.

  • Leider bringt dieser Viewer sehr oft die Meldung "Verbindung zum Teamspeak³ Server konnte nicht aufgebaut werden." während der TS3 Viewer in einem WBB 4.0 der auf denselben TS3 Server zeigt, im selben Moment problemlos funktioniert. Mindestens bei der Hälfte der Seitenaufrufe wo ich diese Box anzeige, kommt die Verbindungsfehler Info. Kann ich so leider nicht gebrauchen.


    Außerdem wäre es schön wenn wie damals im WBB 4.0 eine umfängliche Ansicht möglich wäre, also die Darstellung aller Channels usw. Dieser Viewer zeigt nur ein paar rudimentäre Infos.

    • Das Verbindungsproblem kann ich nicht ganz reproduzieren. Dürfte ich einen Link zum Forum haben?

      Eine Erweiterung für die Channelauflistung befindet sich bei WoltLab in Prüfung.

    • Oh, danke für die schnelle Rückmeldung. Ich sende dir am Abend eine PN mit den Daten (Seite im WBB 4.0 und Box im WSC).

  • Hallo Canna,


    Leider bekomme ich keine Verbindung zu meinen TS3 Server...

    In Whitelist ist der Webserver eingetragen ...


    muss ich unter PLESK bestimmte Einstellungen die der Viewer braucht vornehmen?

    bzw wo oder wie kann ich fehler sehen ....im Admin Backend kann ich keine sehen.




    Software


    WoltLab Suite Forum™-Version
    5.0.11


    WoltLab Suite™-Version
    3.0.11 pl 1

    Server


    Betriebssystem
    Linux



    Webserver
    Apache



    PHP-Version

    7.0.26




    MySQL-Version
    10.0.32-MariaDB-0+deb8u1



    Aktueller UNIX Load
    0.02, 0.05, 0.07






  • Kann ich 2 Teamspeak 3 Server anzeigen lassen, mit diesem Plugin?

  • Gibt es ein Plugin zum Anzeigen der Channels und jeweils der darin aktiven User?

  • hey, habe gerade das plugin geladen und eingerichtet, allerdings habe ich das problem das er manchmal anzeigt "Verbindung zum Teamspeak³ Server konnte nicht aufgebaut werden." Allerdings ist der Server Online.

    • Läuft der Webserver auf dem gleichen Server wie der TS? Wenn nein, axhte bitte die IP des Webservers in die ts query whitelist einzutragen.

    • läuft beides auf einem server

  • Kein Connect da man kein PW eintragen kann . Oder habe ich da einen Denkfehler. Habe erstmal den Verbinden Knopf ausgeblendet. Kann man das irgendwie mit einsetzen als Update.

  • Wie / wo aktiviere ich denn den TS Viewer, der enthalten sein soll?
    Damit meine ich nicht die Box die gerade einmal die Anzahl der Leute anzeigt sondern eine Auflistung der Leute und / oder Channel.

    • Eine Auflistung ist in diesem Plugin nicht enthalten.

    • Ich denke es ist ein TeamSpeak Viewer?

    • Ja, ist es doch auch? :)
      Wenn du die Box über den Inhqlt bzw unter den Inhalt platzierst, werden die Clienten angezeigt.

    • Stimmt ja nicht. Sie werden nur dann angezeigt wenn sie sich auch exakt so benennen wir im WSC.
      Das ist einfach nur Flickwerk und nichts halbes und nichts ganzes.

    • Schwachsinn. Angezeigt werden sie immer. Lediglich werden nur Accounts mit dem Profil verlinkt, die auch so im WSC heissen.

  • Dir ist bekannt das dieser TS Viewer derzeit nen Fehler wirft?



    #0 */templates/compiled/0_wcf_1_tsViewerBoxSidebarRight.php (20):
    wcf\system\WCF::handleError(8, 'Undefined index: virtualserver_status', '*/templates/compiled/0_wcf_1_tsViewerBoxSidebarRight.php', 20, [ 8 items ])
    #1 */lib/system/template/TemplateEngine.class.php (320):
    include('*/templates/compiled/0_wcf_1_tsViewerBoxSidebarRight.php')
    #2 */lib/system/template/TemplateEngine.class.php (546):
    wcf\system\template\TemplateEngine->display('tsViewerBoxSidebarRight', 'wcf', false)
    #3 */lib/system/box/TeamspeakViewerBoxController.class.php (40):
    wcf\system\template\TemplateEngine->fetch('tsViewerBoxSidebarRight')
    #4 */lib/system/box/AbstractBoxController.class.php (51):
    wcf\system\box\TeamspeakViewerBoxController->loadContent()
    #5 */lib/system/box/AbstractBoxController.class.php (63):
    wcf\system\box\AbstractBoxController->getContent()
    #6 */lib/data/box/Box.class.php (271):
    wcf\system\box\AbstractBoxController->hasContent()
    #7 */lib/data/box/Box.class.php (256):
    wcf\data\box\Box->hasContent()
    #8 */templates/compiled/0_wcf_1_user.php (2654):
    wcf\data\box\Box->render()
    #9 */lib/system/template/TemplateEngine.class.php (320):
    include('*/templates/compiled/0_wcf_1_user.php')
    #10 */lib/page/AbstractPage.class.php (308):
    wcf\system\template\TemplateEngine->display('user', 'wcf')
    #11 */lib/page/UserPage.class.php (195):
    wcf\page\AbstractPage->show()
    #12 */lib/page/AbstractPage.class.php (103):
    wcf\page\UserPage->show()
    #13 */lib/system/request/Request.class.php (83):
    wcf\page\AbstractPage->__run()
    #14 */lib/system/request/RequestHandler.class.php (94):
    wcf\system\request\Request->execute()
    #15 */index.php (9):
    wcf\system\request\RequestHandler->handle('wcf')

  • Hi Canna mein TS³ Server und WebSite liegt auf dem selben Server aber ich bekomme nur eine Verbindung mit 127.0.0.1 aber nicht mit der eigentlichen Server IP

  • Das Paket/Plugin darf ich kostenlos und auch erstmal ohne Erweiterungen wie Gruppen Sync etc. nutzen?

  • Bei mir ist das Problem dass der Viewer keine Verbindung zum TS3 Server aufbauen kann trotz richtiger Eingabe der Daten und freigegebenen Ports: jemand ne Lösung parat?

  • Ich habe ein kleines problem. Kann man die Query IP von der Server IP trennen? Der Query port für meinen TS ist dicht nach außen weshalb von der Webseite nur 127.0.0.1 funktioniert aber so kommt man nicht auf den TS server drauf.

    • Du musst ja dennoch einen Queryport haben. Dieser wird von der ts3admin class gefordert, von daher wirds ohne schlecht gehen. Tut mir leid.

    • Das ist aber doof. Dann müsste ich ja um den TS join link aktivieren zu können, eine Sicherheitslücke auf meinem server öffnen :/ Es geht ja nur um den Join link, der query funktioniert aber der Join link der angezeigt wird müsste über eine andere IP als der query laufen...

    • Du kannst manuell das Template ändern und eine IP hinterlegen. :)

    • Könnten sie mir die suche erleichtern und mir sagen wie das template heißt? ^^'

    • Je nachdem welche du verwendest. Such einfach mal nach tsviewer

  • huhu, sorry wenn ich das frage, aber was ist denn die linke Sidebar? ich kenne nur die rechte Sidebar.

    • Hey,
      Im WSC gibt es ja "Boxen". Diese lassen sich an verschiedene Stellen daarstellen. U.a. eben in der rechten Seitenleiste oder auch in der linken. :)

  • Wenn ich das Paket installiere kommt eine Fehlermeldung im Frontend


    Tue, 06 Jun 2017 15:42:21 +0000
    Message: Argument 3 passed to wcf\system\cache\CacheHandler::set() must be of the type array, string given, called in /home/jail/zerogravity/home/borderline-forum/lib/system/cache/builder/AbstractCacheBuilder.class.php on line 41 and defined
    PHP version: 5.6.30-0+deb8u1
    WoltLab Suite version: 3.0.5
    Request URI: /forum/
    Referrer: https://www.borderline-forum.net/forum/
    User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36
    Peak Memory Usage: 134889904/536870912
    ======
    Error Class: wcf\system\exception\ErrorException
    Error Message: Argument 3 passed to wcf\system\cache\CacheHandler::set() must be of the type array, string given, called in /home/jail/zerogravity/home/borderline-forum/lib/system/cache/builder/AbstractCacheBuilder.class.php on line 41 and defined
    Error Code: 0
    File: /home/jail/zerogravity/home/borderline-forum/lib/system/WCF.class.php (299)
    Extra Information: -
    Stack Trace: [{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/cache\/CacheHandler.class.php","line":85,"function":"handleError","class":"wcf\\system\\WCF","type":"::","args":[4096,"Argument 3 passed to wcf\\system\\cache\\CacheHandler::set() must be of the type array, string given, called in \/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/cache\/builder\/AbstractCacheBuilder.class.php on line 41 and defined","\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/cache\/CacheHandler.class.php",85,{"cacheBuilder":"[redacted]","parameters":"[redacted]"}]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/cache\/builder\/AbstractCacheBuilder.class.php","line":41,"function":"set","class":"wcf\\system\\cache\\CacheHandler","type":"->","args":["wcf\\system\\cache\\builder\\TeamspeakViewerCacheBuilder",[],"Verbindung zum Server Query konnte nicht aufgebaut werden."]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/box\/TeamspeakViewerBoxController.class.php","line":28,"function":"getData","class":"wcf\\system\\cache\\builder\\AbstractCacheBuilder","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/box\/AbstractBoxController.class.php","line":51,"function":"loadContent","class":"wcf\\system\\box\\TeamspeakViewerBoxController","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/box\/AbstractBoxController.class.php","line":63,"function":"getContent","class":"wcf\\system\\box\\AbstractBoxController","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/data\/box\/Box.class.php","line":271,"function":"hasContent","class":"wcf\\system\\box\\AbstractBoxController","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/data\/box\/Box.class.php","line":256,"function":"hasContent","class":"wcf\\data\\box\\Box","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/templates\/compiled\/0_wbb_1_boardList.php","line":3105,"function":"render","class":"wcf\\data\\box\\Box","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/template\/TemplateEngine.class.php","line":320,"args":["\/home\/jail\/zerogravity\/home\/borderline-forum\/templates\/compiled\/0_wbb_1_boardList.php"],"function":"include","class":"","type":""},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/page\/AbstractPage.class.php","line":306,"function":"display","class":"wcf\\system\\template\\TemplateEngine","type":"->","args":["boardList","wbb"]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/page\/AbstractPage.class.php","line":103,"function":"show","class":"wcf\\page\\AbstractPage","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/request\/Request.class.php","line":83,"function":"__run","class":"wcf\\page\\AbstractPage","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/lib\/system\/request\/RequestHandler.class.php","line":94,"function":"execute","class":"wcf\\system\\request\\Request","type":"->","args":[]},{"file":"\/home\/jail\/zerogravity\/home\/borderline-forum\/forum\/index.php","line":9,"function":"handle","class":"wcf\\system\\request\\RequestHandler","type":"->","args":["wbb"]}]

    • Daten sind eingetragen?

    • Nein ich hatte erst nur das Plugin installiert und dann kam der Fehler, bei den Daten muss mir noch jemand helfen. Das darf ja aber nicht sein, dass es so einen Fehler im Frontend auswirft nur bei der Installation, oder?

    • Nein. Der Fehler ist auch bereits behoben, ist jedoch von WoltLab noch nicht freigeschalten. Auf meiner Seite findest du das Update. :)
      Wobei genau brauchst du denn Hilfe?
      LG

  • Hallo Canna,
    Vorab mal Danke für deine Arbeit!


    Ich weiß nur nicht was ich falsch mache um ihn zum Laufen zu bringen. Ich habe mir den TS Viewer hier runter geladen und über deine Server auf letztstand gebracht.
    Gebe ich keine Daten oder falsche Daten an so bekomme ich: "Verbindung zum Server Query konnte nicht aufgebaut werden."
    Was Sinn macht, Nett wäre es hier aber vielleicht dennoch die Daten des Server zumindest mit an zeigen zu lassen, auch wenn man nicht weiß ob er läuft oder jemand drauf ist könnte man sich so verbinden. Aber das nur als Notiz für eine spätere Release (sofern es sich umsetzen lässt)


    Nun zu meinem eigentlichen Problem: Trage ich den Serveradmin oder eine Query User ein bekomme ich aber folgende Fehlermeldung:




    Error Type:
    wcf\system\exception\ErrorException


    Error Message:
    Undefined index: virtualserver_status


    Muss oder kann ich hier im ACP oder TS3 noch etwas einstellen?
    Würde mich über Tipps oder noch besser Lösungen freuen :D

    • hmm..Liegt der Webserver und der TS auf dem gleichen Server? Wenn nein, bitte gehe sicher, dass die Ip Adresse vom Webserver in die ts_querywhitelist eingetragen ist. Evt. löst das dein Problem. Ansonsten vielen Dank für dein Feedback. :)

    • Liegt beides am selben Server, IP hab ich dennoch in die whitelist eingetragen.
      Naja dann werde ich mal weiter suchen :)

    • Er sagt ja das eine Variable nicht definiert ist. Ansonsten melde dich einmal bei uns Forum.

    • fyi: Hab's deinstalliert und nochmal installiert... nun gehts :D

    • Komisch
      Aber solange es jetzt geht :)