Blog: Entry Image (Teaser) 3.1.2 pl 1

License Agreement
Lizenz für kommerzielle Plugins
Website
https://darkwood.design/
Supported Versions
WoltLab Suite 3.0
WoltLab Suite 3.1

Provides a new tab for adding professional entry images to blog entries.

This blog extension provides n easy way to add a professional blog entry image to your blog entries. The image is shown on the entry page and entry list.

Features

  • Add an professional entry image right into your blog entry
  • the image will automatically displayed on the entry and entry list page
  • google friends image names from your title
  • automatic scaling for a unified image look
  • saves thumbnails for best performance
  • Alternate double columns list view (see on screens)
  • adds facebook meta tags to show your article iamge while sharing

Images

  • Version 3.1.2 pl 1

    Fixed a bug that could cause links in the filebase to not work correctly.
  • Version 3.1.2

    minor bugfixes
  • Version 3.1.1

    some design fixes for small screens
  • Version 3.1.0

    Support for WoltLab Suite 3.1
  • Version 3.0.1 pl 1

    Fixed an problem with the option "Alternate list view"
  • Version 3.0.1

    The alternate layout can be used now on the entry list of blogs

  • Version 3.0.0

  • Ich möchte Artikelbild hochladen. Etwas steht Hochladen Button Probleme. wcf.acp.style.image.error.invalidExtension

  • Guten Abend.


    In welchem Template wird das Template entryPicture aufgerufen, welches entryImage enthält? Nach was genau muss ich in diesem Template such? Ziel ist es, das Artikelbild vom Teaser im Blog, Hauptansicht über die Überschrift zu platzieren.


    Liebe Grüße


    Webpexel

    • "entryPicture" wird per TemplateListener in die Templates entry und entryMessageList im Event beforeMessageText eingefügt.


      Falls nicht benötigt könntest du das Event in den betroffenen Templates an die gewünschte Stelle verschieben, oder löschen um "entryPicture" manuell einzubinden.

    • Vielen Dank.


      Ich schaue mir das mal an :-)

  • Hallo, ist es absehbar, das Artikelbilder des Artikelsystems der Suite und nicht nur aus dem Blog in der Teaserbox sichtbar sein werden?


    Gruß,

    Doc

  • Grüß Dich,


    ich habe meinen Blog verkauft und benötige auch Dein Plugin nicht mehr. Darf ich das an den Käufer meines Blog weitergeben ? Wenn ja, wie mach ich das bitte ? Hat hier auch ein Kundenkonto :-)

  • Ich habe aktuell das Problem, dass in der Box "Neueste Blog-Artikel" im Dashboard nicht das Teaser-Foto angezeigt wird. In der Blog-Listen Ansicht funktioniert das....mach' ich da einen gedanklichen Fehler? Was muss ich tun, um das zu ändern, d.h. auch im Dashboard das Teaser-Foto sichtbar zu machen? Danke für die Hilfe!


    http://spielraum-froschlache.de/

    http://spielraum-froschlache.de/blog/

    • In der Box ist das BIld aktuell nicht verfügbar und müsste manuell eingebunden werden. Hierfür muss in entsprechenden Template der Box folgender Code eingefügt werden. (im "messageText"-DIv) {include file='entryPicture' application='blog'} (ungetestet und ohne gewähr)

    • Das ist doch die gleiche Box wie im Blogbereich, oder? Liegt der Fehler bei mir?

    • Im Blog ist es keine Box sondern ein Blog-Template. Ich werde prüfen ob ich das per Update noch in der Box berücksichtigen kann.

    • Achso, Danke Dir!

  • Guten Morgen,


    ich habe es gestern installiert und mir ist heute aufgefallen, das wenn ich einen Artikel zu Facebook teilen möchte, das das Bild, was als Dateianhang im Artikel ich hochgeladen hatte, entweder das Logo von meinem Blog oder aber dieses Bild angezeigt wird:


    https://up.picr.de/32585944ty.png


    Vor der Installation hat alles einwandfrei funktioniert. Bin etwas ratlos, woran es liegen könnte. Kannst Du mir bitte behilflich sein ? :-)

  • Das geht nur für Blog Artikel richtig? Für das CMS Artikel System geht das nicht oder?

  • Hallöchen es scheint ein Problem im zusammen Hang mit der Filebase von Viecode zu geben kannst du dir das mal anschauen?


    https://www.viecode.com/suppor…l-verweist-auf-den-blog/?

  • Super Plugin, gefällt mir gut!

    Aber einen Verbesserungsvorschlag hätte ich: Ich würde gerne unter dem Bild eine Unterschrift optional einfügen können. Sei es als Copyright-Hinweis oder eben als Bildunterschrift. Wäre toll, wenn Du das noch einbauen könntest.

  • Vielen Dank an den Entwickler dieses Plugins, bin bisher sehr zufrieden mit diesem. ;)

  • Es wirft leider die bereits abgehangenen Bildern aus den WSC Medien raus :/ ein wenig doof nun muss ich ALLE meine Artikel durchgehen und die Bilder wieder einfügen

    • Wie genau meinst du das? Hast du den Blog neu installiert?


      Wenn das der Fall ist, kannst du das per MySQL automatisiert nachtragen.


      SQL
      1. UPDATE blog2_entry
      2. SET image = (
      3.   SELECT image
      4.   FROM blog1_entry
      5.   WHERE entryID = blog2_entry.entryID
      6. )
    • Nein der Blog war vorher da. Habe dein Plugin installiert und dann waren alle Medien (Bilder) futsch.

    • Das kann nicht sein. Zwischen den "Medien" des Frameworks und dem Plugin gibt es keinen Zusammenhang. Da muss etwas anderes schief gelaufen sein. Bitte wende dich an WoltLab bei weiteren Problemen mit den Medien.

  • Aktuelle Version, habe aber auch das Problem, dass der einmal getestete SplitView, obwohl ausgeschaltet, noch immer angezeigt wird, zumindest wenn ich in der Blog-Übersicht direkt auf einen Blog klicke, anstatt "Artikel" oder "Meine Artikel" zu klicken. Abgesehen davon wäre es super, wenn der Splitview erst bei 2+ Beiträgen / Blogs einsetzt. Aber vermutlich zu kompliziert?


    Außerdem klebt der Text in der Split-View Ansicht ohne margin am Seitenrand (s. Screenshot) - hat jemand den entsprechenden Code für die CSS zur Hand? Danke!


    [Blocked Image: https://dsc.cloud/danvanmoll/Screen-Shot-2018-02-20-at-19.02.54.jpg]

  • Hallo,

    wäre es theoretisch möglich die alternative Ansicht auch auf der Einstiegsseite zu verwenden? Bei mir klappt das derzeit nur in den Kategorien.

  • Hallo, ich möchte einen wahrscheinlichen Fehler melden. Nachdem ich heute das Update von Blog: Artikelbild als Teaser installiert habe, zeigt mir der PC unter Benutzer Online fast 500 Einträge unter Blog Artikel an, die angeblich gleichzeitig Online sind. Dabei sind nur 4-5 Benutzer online. Viele Grüße

    • Edit: Ich habe das Plugin deinstalliert und jetzt werden mir nur 3 Gäste online angezeigt. Vermutlich war das der Fehler. Viele Grüße

    • Da kann es keinen Zusammenhang geben.

    • Es war ein Fehlalarm. Ich hatte vor kurzem wieder einen User online, der 30 mal unter den Blog-Artikeln Online war. Dein Plugin verursacht nicht den Fehler. Alles gut bei Dir. Viele Grüße

  • In den Optionen hab ich doch die Wahl, ob ich den Blog als normale Ansicht oder im zwei-fenster Modus, also Split view angezeigen möchte. Seit dem ich die Funktion einmal ausprobiert habe, krieg ich das nicht wieder auf Standard. Ausmachen hilft nicht. Wenn man die Seite neu lädt (auch nach Browser Cache Leerung), dann ist es für einen Bruchteil einer Sekunde wieder normal, nur um danach wieder in den Split view zu gehen.

    Was hat das mit auf sich ? Die Option mit dem Split view ist doch von dem Plugin hier, oder nicht ?


    Mfg


    Wolf

    • Bist du dir sicher, dass du die Option deaktiviert hast? (und sie auch auf deaktiviert steht)
      Du kannst auch mal probieren den Cache im ACP zu löschen. Technisch sollte es aber nichts damit zu tun haben. Es wird einfach geprüft ob die Option angeschaltet ist und dann per Javascript ein Klassenname zum Body hinzugefügt. Ist die Option nicht gesetzt existiert das entsprechende Script garnicht erst.

    • Bei mir hat die Funktion keinerlei Auswirkungen. Zunächst stand es bei mir auf Aus und jetzt habe ich auf Ein umgestellt doch nach wie vor sehe ich die großen Bilder. ACP- und Browser- Cache habe ich schon gelöscht.

    • Genau anders rum als bei mir quasi. Seit dem ich das auf den Dual View umgeschaltet habe, krieg ich es nicht mehr ausgeschaltet.

    • Ich schliesse mich dem an . Das selbe Problem habe ich auch.

    • Danke der Fehler wurde gefunden und ist in der nächsten Version behoben.

  • Ich habe gleich mehrere Fragen, die unseren Blog beteffen, wobei ich eigentlich die Einstellung ähnlich diesem Blog haben möchte:


    1. Wie bekomme die Bilder in dieser Artikelansich kleiner und gleichmäßiger - ich wundere mich da ein wenig, weil die jetzigen Bilder beide die Ausmaße 600x315 haben und dennoch das linke Bild kleiner als das rechte Bild angezeigt wird...komisch
    2. Ich würde - wie auf der Beispielsseite - auch gerne nur die Schlagworte unter dem Bild und das Datum haben... wie?
    3. Im eigentlichen Artikel wäre es gut, wenn das Bild groß über dem Artikel angezeigt wird... wie?
    4. Letztlich finde ich auch die Formartierung der Beispielsseite besser, so z. B. die Striche unter der Überschrift... wo kann ich das ändern?
    5. Auch finde ich diese grau-unterlegten Artikelbilder in der Vorschau mit den Überschriften nicht schlecht. Wie bekomme ich das hin?
    • Der verlinkte Blog ist leider nur bedingt vergleichbar, da dort noch das alte WCF2 im Einsatz ist und ein individuelles Design verwendet wird. Generell ist ein ähnlicher Look aber möglich. Mit der Einstellung 600x315 bist du bereits gut unterwegs. Ich empfehle die Bilder vorab mit einem Bildbearbeitungsprogramm auf diese Dimensionen zuzuschneiden um damit diese beim Upload nicht skaliert werden müssen.


      Den Effekt mit dem grau bekommst du per CSS hin. z.B. so:


      .entryImage:hover img {
      transition: all .2s;
      -webkit-filter: grayscale(70%);
      -moz-filter: grayscale(70%);
      -ms-filter: grayscale(70%);
      -o-filter: grayscale(70%);
      filter: grayscale(70%);
      opacity: .7;
      }

    • Danke für die Infos, werde ich heute Nachmittag ausprobieren! Beide Bilder habe ich mit Photoshop auf die Größe 600x315 eingestellt. Dennoch werden die Bilder im Blog unterschiedlich groß dargestellt... ich sehe allerdings überhaupt keinen Grund dafür, dass das so passiert. Woran könnte dass denn liegen? Ich meine: Das fällt ja sofort auf!

    • Am besten schickst du mir mal einen Link mit Account, dann schau ich mir das mal an.

    • Habe ich Dir Gestern per PN geschickt

    • Ist angekommen und wird in Kürze bearbeitet.

  • Wer hat das Plugin installiert? Auf welcher Homepage kann ich mir das mal ansehen? Grüße

  • Bei mir 3.0.9 wird zwar das Bild angezeigt, aber nicht nebeneinander sondern übereinander. Auch das Teaserbild wird mobil nicht skaliert. Wo kann man das beeinflussen? Grüße Enrico


    screenshot.png

  • Klasse gemacht! Wäre es evtl. möglich zwischen dem Teaser Foto und dem Text eine Leerzeile einzufügen?

  • Wäre es Möglich das ganze auch Mobile Optimiert hinzubekommen?


    Sieht etwas unschön aus wenn man wie ich auf eine Bannergrösse geht die über die gesammte länge reicht. Mobile wird dann der Banner einfach abgeschnitten.

    • Danke für dein Feedback. An welcher Stelle meinst du genau?

    • Moin, habe dir ein Bild via Konversation zugesendet wie es Mobile aussieht.


      Als grösse im ACP habe ich 980 x 220 festgelegt damit es über die ganze Breite des Blogs reicht und ein Banner dargestellt wird. Sieht im Browser auch sehr schön umgesetzt aus. Nur eben Mobile wird der Banner (Artikelbild) abgeschnitten.

    • Danke dir, ich schau mir das die Tage an.

  • Danke Danke Danke :-) Einfach Spitze das sowas kommt ;-) gleich gekauft

  • Kommt für mich ein wenig zu spät. Schade, dass ich den Blog nicht mehr nutze. Dieses Plugin wertet den Blog um Einiges auf! :)

    • Danke für dein Feedback. Ich habe das bereits im letzten Jahr in meinem eigenen Blog umgesetzt, in dem es sehr gut ankam. Da ich immer wieder danach gefragt wurde, habe ich das ganze nun als Plugin für alle umgesetzt. Falls du den Blog doch irgendwann wieder im Einsatz hast, weißt du wo du die Erweiterung findest. :)

    • Wenn du jetzt noch ein Plugin in petto hast, mit dem ich die Berechtigungen für einzelne Blogs anders verwalten kann, dann fange ich an zu weinen... ;)

Customers Who Bought This File Also Bought