WoltLab Cloud Font Awesome 5 für WoltLab Suite 1.0.1

Ersetze die Font-Awesome-4-Icons in deiner WoltLab Suite mit der aktuellen Version von Font Awesome 5 und sei dennoch vollständig abwärtskompatibel zu den Icon-Namen von Font Awesome 4.

Ersetze die Font-Awesome-4-Icons in deiner WoltLab Suite mit der aktuellen Version von Font Awesome 5 und sei dennoch vollständig abwärtskompatibel zu den Icon-Namen von Font Awesome 4.


Dieses Plugin fügt die kostenlosen Icons von Font Awesome 5 hinzu, wodurch du eine größere Auswahl an Icons hast als mit Font Awesome 4. Außerdem wurde viel Zeit und Arbeit in diese neuen Icons für ein noch besseres Icon-Set gesteckt. Schau dir Font Awesome für mehr Details an.


Nach der Installation musst du nichts mehr tun. Font Awesome 5 ist einsatzbereit!

Images

  • Version 1.0.1

    – Fehlerhaftes CSS behoben, wenn die WoltLab Gallery installiert ist

  • Version 1.0.0

    – CSS durch SCSS ersetzt

    – Laden der Schrift verbessert

    – Anzeige mancher Icons korrigiert

  • Hallo Black Rider,


    mir fehlen auch einige ICON's die vorher vorhanden waren.


    Hier der Link zum Forum: tourneo-forum.de

    • Danke für die Antwort.


      Habe soweit mit CSS gelöst nur was ich schade finde ist das man die Icons doppelt eintragen muss,


      Einmal mit dem -o:before und einmal ohne dem -o.


      Damit Sie auch mit der Farbe für neue Beiträge angezeigt werden.


      So sieht das bei mir im CSS aus:


  • Kann es sein, dass fa-folder-open-o fehlt?

    Siehe https://cwalz.de/forum/


    Grüße

    • Es sieht mir eher so aus, als ob du das nochmal an einer Stelle überschreibst:

      CSS
      .wbbBoardList .icon32.fa-folder-open-o::before, .wbbBoardList .icon32.fa-folder-open::before {
      content: "\f0e6";
      font-size: 25px;
      }
      Thanks 1
  • Super, endlich ... darauf habe ich nur gewartet!

    Habe allerdings 2 Fragen:

    • Wird es ggf. die Möglichkeit geben die Pro-Variante zu aktivieren?
    • Kann es sein, dass in der Auswahl der Forenicons noch einige Icons fehlen?
      Genauer gesagt fehlt mir z.B. das Xbox Icon, welches in Version 5.0.0 in der Free Version hinzugefügt wurde
      https://fontawesome.com/icons?d=gallery&q=xb&m=free
    • Aktuell wird die manuelle Auswahl der Icons bei Foren, Trophäen und ähnliches im Administrationsbereich noch nicht unterstützt. Bevor das nicht läuft, mache ich mir auch noch keine Gedanken darum, die Pro-Version der Icons nutzbar zu machen. Generell ist das geplant, allerdings kann ich gegenwärtig nicht sagen, ob oder wann das der Fall sein wird.

      Thanks 2
    • Selbiges hier - so eigentlich nicht nutzbar. Schade, gibt's schon neues zu den fehlenden Icons?

    • Nein, leider nicht. Aktuell sehe ich leider keine Möglichkeit, das entsprechend umzubauen, da mir hier die erforderlichen Möglichkeiten innerhalb des Cores fehlen.

  • Freute mich erst über dieses Plugin. Aber scheinbar verträgt es sich nicht mit dem Menü Icons Plugin von SoftCreatr. Die werden nach Installation von FA5 leider nicht mehr angezeigt.

    Like 3
    • Hab einmal "nachgefragt" bei SoftCreatr, ob das Plugin überarbeitet wird.

      Quote from Email - Kontaktformular

      Davon abgesehen, dass das Kontakt-Formular für derartige Dinge nicht gedacht ist, werden wir keine Anstalten machen, das Plugin in irgendeiner Weise zu unterstützen.

      Die 'Menü Icons' sind bei mir rausgeflogen, genauso wie die Erweiterung '[Entwickler] Font Awesome-Werkzeuge' von SoftCreatr. Die haben nur die alten FA Icons.

      Thanks 1
    • Na das ist ja ne nette Antwort von SoftCreatR. Werde die Menü-Icons dann auch rausschmeißen. denke ich. Danke für deine Mühe !

  • WOW! Super, obwohl gesagt wurde, es wäre nicht möglich.


    Bei mir werden aber zwei Icons im Frontend nicht angezeigt "user-circle-o" und "comments-o". Im ACP werden diese angezeigt.

    https://streamable.com/psqc07


    Muss ich noch etwas aktualisieren?


    Edit: Das Icon "archive" habe ich ebenfalls für ein Archiv ausgewählt. Im ACP wird es angezeigt, aber im Frontend zeigt er mir das Standard-Icon "Folder" an.


    Cache Browser und im ACP gelöscht. Sowie anzeigen aktualisiert.


    LG